Questions for people using Thinkfan

I want to use thinkfan on QubesOS, but I don’t know how to use it correctly.
I installed lm_sensors and thinkfan and edited various files, but thinkfan does not start.
It’s confusing when I search because everything says different things.

If anyone is using thinkfan, please let me know how you did it.

1 Like

Did you try this?

What errors did you get?

this is my error. i don’t know how to fix.

[user@dom0 Desktop]$ sudo modprobe -r thinkpad_acpi && sudo modprobe thinpad_acpi
modprobe: FATAL: Module thinkpad_acpi is in use.
[user@dom0 Desktop]$ sudo thinkfan -n

ERROR: The `sensor' keyword is deprecated. Please use the `hwmon' or `tp_thermal' keywords instead!

As stated in post that I linked in my previous reply:

Did you set force_load=1?

This command should be used after you’ve stopped thinkfan service:

i stoped. but same error.

Did you reboot after editing /etc/modprobe.d/thinkfan.conf?
If yes then does this work?

sudo modprobe -r thinkpad_acpi && sudo modprobe thinkpad_acpi

What’s the output of this command?

systemctl status thinkfan

Change the /etc/thinkfan.conf as well:

yes. i restarted QubesOS.

Change /etc/thinkfan.conf to this (you need to change the lines started with sensor to tp_fan and hwmon):

tp_fan /proc/acpi/ibm/fan
hwmon /sys/class/thermal/thermal_zone0/temp

(0,     0,      42)
(1,     40,     47)
(2,     45,     52)
(3,     50,     57)
(4,     55,     62)
(5,     60,     72)
(6,     65,     77)
(7,     70,     80)
(127,   75,     32767)

Reboot Qubes OS and then check the output of this command again:

systemctl status thinkfan
[user@dom0 Desktop]$ systemctl status thinkfan
● thinkfan.service - Thinkfan, the minimalist fan control program
     Loaded: loaded (/usr/lib/systemd/system/thinkfan.service; enabled; vendor preset: disabled)
     Active: active (running) since Tue 2023-12-19 06:21:13 UTC; 10min ago
   Main PID: 1763 (thinkfan)
      Tasks: 1 (limit: 4618)
     Memory: 1.5M
        CPU: 70ms
     CGroup: /system.slice/thinkfan.service
             └─1763 /usr/sbin/thinkfan -n -q -b0

Dec 19 06:21:13 dom0 systemd[1]: Started Thinkfan, the minimalist fan control program.
Dec 19 06:21:13 dom0 thinkfan[1763]: Temperatures(bias): 80(0) -> level 7
[user@dom0 Desktop]$ 

It works! Thank you very much for your help.
My original goal was to run more fans because the heat would shut down the Qubes.
If I want to increase the fan speed, I can change the number in /etc/thinkfan.conf, is it right?

Yes, you can change the fan profile to your liking:

#  Syntax:
#  LEVEL is the fan level to use (0-7 with thinkpad_acpi)
#  LOW is the temperature at which to step down to the previous level
#  HIGH is the temperature at which to step up to the next level
#  All numbers are integers.
1 Like