QubesOS freezes overnight

When I leave QubesOS idling overnight, in the morning it cannot wake up from its i3lock. The only recourse I have is then to force shutdown, which is something detrimental.

I remember reading previous threads also mentioning this bug. They were alleging that the qubes updater overnight causes freezes. Has there been any new developments in resolving this? I am unable to leave QubesOS idling through the night, which is constraining my possible future usage scenarios, and really just not appropriate.

Is disabling the cron.daily script, /etc/cron.daily/qubes-dom0-updates.cron a temporary solution to that?

Bump?
It happened again recently. I checked journalctl and before the forced reboot, the very last entry was about cron.daily executing 0anacron script. Is this script causing freezes?

At the moment I’m using

xen_version : 4.14.5
Linux 5.19.9-1.fc32.qubes.x86_64

and didn’t face it recently… Updated dom0 though without crashes…

I have constant issues with Qubes freezing on me when left idle. Estimates based on my observations:

  1. After 1 hour: ~30% chance of freezing
  2. After 2 hours: ~70% chance of freezing
  3. After 3 hours: ~100% chance of freezing

For me, locking the screen seems to increase the chance of freezing, leaving me to decide whether I would rather take the security risk of leaving it unlocked or lock it and accept the higher risk of a crash. Not something you want from a security-focused OS.

2 Likes

This is about right as to what I am experiencing, as well.

I also experience frequent, intermittent, random shutdowns of sys qubes and wonder if these two issues are related. Do you experience this as well? I will be testing increasing the memory allocated to those qubes to see if that improves.

No I don’t experience those. That might be your hardware. You can check my forum profile to see and compare the hardware I use.

This is so annoying. I just experienced another total system freeze. The i3wm got frozen on me and I had to force a restart using the power button. Glad I wasn’t in the middle of editing a text file or something, but this is just annoying.

It seems like my QubesOS has to experience such freezes at least once a day. If it experiences this once in a given day, I can be rest assured that I will not experience such freezes again for that day.

But this is no way to use an OS: awaiting for your daily dose of total system freeze so that you can force reboot and finally use the OS with “peace of mind” for the remainder of the day (!).

So why don’t you try my kernel version?

I am currently using
xen_version : 4.14.5
Linux 5.15.64-1.fc32.qubes.x86_64

On the Qubes Global Settings, I only have 5.15 kernel available to select. How do I get the 5.19 kernel be used?

Global settings tell you the version used by the VMs. You can use uname -a in dom0 to see which version dom0 is using.

You probably need to enable the unstable repository, without it kernel-latest gives you 5.18 I think.

1 Like

And do update and even --action=upgrade after that

1 Like

can you spell out the exact commands for what you are describing?

How to enable the testing repos

Kernel upgrade

$ sudo qubesctl --show-output state.sls update.qubes-dom0

$ sudo qubes-dom0-update kernel-latest

Changing default kernel

$ sudo qubes-dom0-update --action=upgrade