QubesOS 4.1 laggy

Hi, My qubesOS was working smooth and perfect for months but suddenly few weeks back i started to notice the mouse lagging.

I thought the machine is stressing or problem with video driver? I don’t what might actually cause this error and don’t know where to start troubleshooting and find the error and fix it.

Although I tried to check if RAM is the issues as i run many appvm’s simultaneously. I started to notice stopping the appvm’s sometimes work sometimes doesn’t solve the issue.

Can anybody please guide me where i should look. The system was running fine until a update messed up or something. I really don’t know.

I don’t want to reinstall my whole QubesOS and import the template and appvm because i have configured my system following this guide [Qubes OS Installation - Detached encrypted boot and header]

UPDATE : I was troubleshooting what might be the issue and started 2-3 appvm’s the system just crashed and rebooted itself. I don’t know how to check what might have caused the problem
anyways results of the command last-x | head | tac

who -b
system boot 2022-03-13 20:58

user (to lvl 5) 5.10.104-1.fc32. Sun Mar 13 12:43 - 15:28 (02:45)
user :0 Sun Mar 13 12:43 - crash (08:14)
user tty1 :0 Sun Mar 13 12:43 - crash (08:14)
reboot system boot 5.10.104-1.fc32. Sun Mar 13 20:58 still running
runlevel (to lvl 5) 5.10.104-1.fc32. Sun Mar 13 15:28 still running
user :0 Sun Mar 13 15:28 still logged in
user tty1 :0 Sun Mar 13 15:28 still logged in

I believe it’s similiar to this sys-usb kworker events CPU consumption · Issue #5823 · QubesOS/qubes-issues · GitHub , don’t have idea how to permanent fix this, but restarting sys-usb temporary fix the problem.

I don’t have a sys-usb. I guess I created disposable sys-usb and I’m currently using Bluetooth mouse and keyboard.

Should I create new sys-usb and troubleshoot?