Qubesd failing to start

Tried using the menu, it didnt open, so I thought of opening the qube manager with xfce’s default menu, it also didn’t work. When I tried to launch it manually though the terminal, it gave a no such file or directory error for qubesd service, so I tried starting it with systemd and it failed, journalctl didnt tell me anything I didnt know, except a warning “start request repeated too quickly”. Looked the errors up on google, but didnt even find any mentions of qubesd

Does this issue persist even after reboot?
When did it start?
After dom0 update?
Or did you change some files / run some commands in dom0?

The issue persists on reboot, and this is a fresh install, I haven’t changed anything

I can just make some random guesses about the cause of this issue:

  • Maybe virtualization and/or IOMMU are not enabled in BIOS
  • Maybe there was some error during installation and it didn’t finish successfully
  • Maybe you have a corrupted Qubes OS installed ISO or installation media

I’ll try reinstalling then, virtualization is enabled and I did do every manner of integrity verification I know of before burning the ISO

Did you test media before install?
It’s the default GRUB boot menu entry in Qubes OS installer.

Yes, just finished reinstalling. This issue popped up again right at the end of the final setup.

Maybe to supplement the suggestions:

  • Do you know of the possibility to verify the usb integrity after flashing it?
  • Do you know that you can verify the media after inserting and booting from it?
  • Did you try different usb’s?
  • Did you install Qubes on this machine before (with the same settings for bios, …)?
    If so, did it work there?

Btw, just to make sure, are you meaning the menu in the upper left corner?

Maybe you’re booting into Qubes OS dom0 without xen for some reason as described here:

Also how much of the disk space did you use for Qubes OS installation?

This might actually be the case. When running qubesd directly I got an error ralted to xen (another file or directory not found). I had 50G for my root partition, 140G for my /home and 1G for /boot/efi. After reading that issue I still don’t really understand what they did though, I’m not very familiar with Qubes, could someone maybe point me somewhere I can understand what I need to fix this?

I only know about using the test media and install option on the grub menu, this is the only usb drive I have, and I have used it to install a lot of distros, I don’t think it’s the problem, and yes, I had, couldn’t get past the install config screen because of a bug when trying to install qubes with Ventoy. And yeah, the one with QubesOS’ logo

1 Like

What about /boot partition?
How did you configure Qubes OS partitions in the installer?
Did you dedicate the whole drive to Qubes OS or are there some other OS partitions there?