Failed to connect to qubesd service: [

After install at first log on I got this error.

It hasn’t appeared since. I can’t open any create qubes menus.

[Domo] Error

[‘/usr/bin/qubes-prefs’, ‘default-kernel’, ‘5.15.94-1.fc32’] failed: stdout: “”

stderr: "qubes-prefs: error: Failed to connect to qubesd service: [Errno 2] No such file or directory

In the boot log it says “failed to start memory management daemon”.

But I have Vt-d and Vt-d enabled in bios and it’s supported by my Cpu. I meet all hardware requirements

Lenovo T430, UEFI, secure boot off.

Okay. So what has happened is that for some reason it did not install a bootloader to the EFI partition that I use.

My EFI partition is on another drive. Even if I select both drives during installation and only clear space on the drive on which I want Qubes it doesn’t recognise that the second drive has the EFI partition and creates a new EFI partition on the Qubes drive.

I thought this was my fault or I had my boot priorities set incorrectly. so

Because I use grub2. I tried reinstalling grub2 from Manjaro…copying the qubes/fedora directories to my grub2/boot partition and regenning the boot files. This gave me a Qubes install without xen in the boot options, hence the error above.

So I copied the menu entries the grub.cfg from the new EFI partition to the old one, but now the display is black at boot, so I have to boot blind :worried:

I also noticed that the xen.cfg wasn’t just empty… it wasn’t there at all. I created the file manually and put in the details on the UEFI boot problems page. Shouldn’t post-install scripts do little checks for important things like this?

Now I get a different problem where grub is just a black screen, but the instructions on the UEFI problems page don’t work.

Also,…Qubes uses Grub not Grub2? Can I get them to play nice? I’ve heard about chainloading, but I don’t know how to do it here.

The Qubes services now run AOK. :grin: Proud of myself. How do I kick off the initial template installation that should happen after first boot? I really want to sort my bootloader problems properly, and then I can begin properly using Qubes.

Please can someone help me?

Oh I also saved the logs folder from the freshly installed Qubes install. I don’t know if that’s any help?

Can someone is able to help me with this issue please?

Hi, could you reformulate your issue(s) ? in a short way if possible.
If there is several not related issue, try to separate them on different topic.
Not sure what issue is solved and what is not ?

If any error, could you paste the exact and complete message.
The exact command you used and when, can be useful too. :slight_smile:

To complete my previous answer.

If not happened again, solved by update … ?

Maybe something like ?

Does this means that sys-net and sys-firewall working ?

If you have internet see
e.g. (in dom0) qvm-template install fedora-37

If you do not have internet, you need to mount your Qubes OS install USB,
copy the template to dom0 and install it. (or do a fresh install).