Qubes will not boot on 4K Monitor

I have a Qubes 4.1 install which works fine on a 1080p monitor but will not boot when attached to a 4K monitor. I have just booted it into the 1080p and then switched the cables and it was absolutely fine so there is an issue in the boot process somewhere.

The boot screen comes up fine and I can select an option between Qubes and Advnaced options for Qubes.
After this the screen firstly goes black, then flickers a single colour for a fraction of a second, then goes black again for some minutes. Eventually it brings up a CLI prompt at the top left for the encryption password for my drive. I am able to type this in and it is accepted however the the screen goes black with a single underscore at the top left. Some time later the 3 dots appear which would signify loading but very near the top left instead of in the middle of the screen and they are much smaller in size. The last one is highlighted slightly but this does not seem to change.
Some time later, maybe 10 minutes or more, the login prompt appears. This seems to operate as it should and has the toolbar across the top. However upon successfully logging in only the background is viewable. There is no toolbar but the mouse is able to move around. This is an effective dead end as without a toolbar nothing can be done.

Any suggestions on how to fix this would be appreciated.


What model of your PC? Specifically, what are the specs. Can you list them out?

Sorry, should have put that in the initial post.

It’s a Dell XPS 8940. 11th gen i7-11700. 16GB DDR4 2933Hz. 512GB NVMe SSD + 1TB 7200RPM drive (Qubes is on the nvme and it boots from this). I’m using the on board graphics for this and connecting with HDMI.

I do have an Nvidia card but I had even less success when booting with that in and created a separate post as the symptoms were different to this issue and common over the two monitors.

Do you have the latest kernel of Qubes?

If not, type this command in dom0 terminal:

sudo qubes-dom0-update kernel-latest kernel-latest-qubes-vm

That is extremely weird….

What would be really helpful is the output of:

  • lspci -vv
    • Shows your chipset, CPU, graphics controller and other PCI devices
  • xrandr -verbose with 1080p monitor plugged in
    • Shows the EDID and monitor announcement
  • xrandr -verbose with 4K monitor plugged in
    • Might show something that’s causing your issue on boot

GRUB usually works on most GPUs (although, to be fair, I have had issues with an HP Omen board with an nVIDIA card, it stays blank until the Linux kernel loads nouveau, and then it works, and I still don’t know why…)

So plymouth is also having trouble showing up. That’s useful information.

Maybe try to add the following kernelopt:


It is used by the installer ISO to force the Intel graphics modules to “show something no matter what”, more or less….

Those should be hidden by plymouthd and shouldn’t be showing up. It sounds like something is a little messed up with your Xen and Xorg configs.

Do they show up when you boot with your 1080p monitor plugged in…?

Ok, so the greeter works as expected…

Yeah; that’s definitely not supposed to be happening :woozy_face:

Can you right-click and open a terminal?
Can you get to a tty?


In any case, as @HPOA909 said, it’s always worth trying the latest kernel, but I have a feeling there’s something else going on besides kernel modules…

1 Like

Once I had a problem that sounds similar.
I was trying to boot Linux on a 4k Screen, which would not work.
I could not see the messages from EFI/BIOS firmware.
I could start Windows 10, which worked fine.

As the tower had a graphics card which allowed me to plug in two screens, I could see the smaller screen, it would boot. I could make adjustments in the BIOS/EFI if needed. And like this case, the 4K screen would begin working.

I hypothesized it is possible the SSD with Linux was so fast that the Firmware might not have been able to keep up. Windows boot was slow enough that was not a problem. I guess that is my prejudice against Windows speaking. As the tower is no longer online. I just now use the tower with Windows 10 to watch movies.

I think I am suggesting the problem you have is in the EFI/BIOS. Maybe slow down the boot in some way(???)

This problem occurs with me when I have the display at 4K/60Hz. It works fine 4K/30Hz. I don’t think the BIOS/UFEI screen supports 60Hz. I wonder if the problem is the motherboard’s lack of compatibility with 60Hz refresh rate.

Maybe you have the display set to Enhanced HDMI 60Hz. Try changing the display to 30Hz.

I did not and it upgraded 5.15 → 5.18. However symptoms remain the same

OK so the output of lspci -vv can be found here. (It seemed a bit verbose for a forum post)

xrandr --verbose (1080p)

xrandr (4K) in another post as I cannot put more than 2 links in the post

There is no right click in the final blank dektop state.

I don’t know how I’d get to a tty in qubes. Is there a keyboard shortcut for this?

I will get back to you on whether the dots show up on 1080p and also the result of adding the kernel option once I have done these tests

xrandr --verbose (4K)

When I plug in after booted up it is only at 30Hz. I can’t see an option on the monitor to slow down the refresh rate. I don’t think this is the issue unless someone can point me towards some commands to test this.

This made no noticeable difference to behaviour and nothing else on the screen

Maybe that’s not the problem for you then if you see 30Hz after bootup. I don’t know your brand monitor to know where the settings are located.


They do not show up on the 1080p monitor. I have a big Q in the middle and progress bar at the bottom

I don’t know if this is relevant to my issue but I’ve caught an error message at the grub stage. Perhaps since setting the advised kernelopt ( i915.alpha_support=1).

It flashes up very quickly on the 1080p monitor, I had to take a picture to capture it.

"Welcome to GRUB!

error: file `/EFI/qubes/fonts/unicode.pf2’ not found."

Sorry I’m not familiar with Samsung.

For this to work the one should first check if it’s even available for the igpu.

$ modinfo i915 | grep ‘^parm:’

Here’s mine journalctl record for it:

Sep 27 xx:xx:33 dom0 kernel: i915: unknown parameter ‘alpha_support’ ignored

1 Like

Did you try to set 4k as primary and the only one monitor from there (right click on the Desktop/background-> Apllications->System Tools->Display)?