[qubes-users] Issue with "Qubes release 4.2.0-rc3" | USB Installation Media not detected in UEFI BIOS

Hi Team,

I am facing an Issue with “Qubes release 4.2.0-rc3”:-

I made installable USB media for “Qubes release 4.2.0-rc3” as detailed here , but after making this, my USB was not being detected in my UEFI BIOS boot menu.

This is how I made USB installable media:-


I also tried making installation media using Ventoy, but with this method, got many errors while startup of installation of this test Qube release version.

My PC configuration is like as follows:-

CPU: Intel i5 13600K
Motherboard: ASUS TUF Gaming Z790 PLUS WIFI
RAM: 32 GB

so please suggest how can I install “Qubes 4.2.0.RC3” and by when, we are planning to release 4.2 release?

Thanks and Regards


Hi Team,

FYI, Attaching Rufus configuration for preparation of USB installation media.

Thanks and Regards

Hi Team,

Any clue on this please?

Thanks and Regards

Hi, Rahul,

your USB medium seems to be faulty. Have you checked that the image on the USB medium matches the ISO image you have downloaded?

If you have a Linux machine somewhere, you can try this:

Best Regards,

I actually had a similar issue. It ended up being a BIOS that refused to detect rc3 is ISO format. Mounting the ISO and copying the files over to a FAT formatted USB got around the boot issue but the qubes installer doesn't see it's root partition then.

The working solution was to insert both the FAT formatted USB and the ISO one (just burned using DD). That way there's an EFI partition for the UEFI to boot and a proper Qubes USB for the installer to use. Not pretty, but it worked.

I didn't try the ISO, and I know little about UEFI booting, but current Linux ISOs seem to be partitioned CD-ROMs: A type 0xef EFI partition (4MB), and a type 0x17 hidden NTFS partition (that is actually ISO9660, containing the actual files)...

Kind regards,

Thank you Tobias and other folks and really sorry for delayed reply on this.

This is what I did:-

  1. Updated motherboard BIOS version to latest one.
  2. Verified ISO file should be same as downloaded one, it was corrupted so corrected later.

By doing so, I was able to see Qubes 4.2.0 RC4 installation UI, but was not able to resolve issue of Installation source, so I decided to use Rufus made USB installation media, for this, when I tried to make USB installation media for “Qubes-R4.2.0-rc4-x86_64.iso” by rufus, I was seeing only UEFI (non CSM) option as follows:-See attachment “4.2.0V.png”

but with current stable version of QUBE OS “Qubes-R4.1.2-x86_64.iso”, this issue was not replicable:- See attachment “4.1V.png”

To fix this issue, CSM support should be enabled in my motherboard BIOS, but I don’t have any external graphics card and and as per “https://www.asus.com/support/FAQ/1045467”:-

Intel 500 and the latest series of chipsets do not support VBIOS display, so the integrated display does not support legacy boot, use a graphics card that supports VBIOS to enable CSM.

so this means, in Qube OS 4.2.0 iso file, we are forcing to enable CSM, but in 4.1 version , we were not.
I think, We should not force need of CSM support for QUBE OS 4.2.0 version too.

I hope, this helps to understand cause of issue.

Please let me know, if any correction or any information on this please.

Thanks and Regards

Hi Team,

I put more efforts on this and fixed issue at my end itself.

If you see rufus download page “https://rufus.ie/en/”. here a bug has been fixed in Rufus version 4.2, below are fixed issues/enhancements in 4.2 version of Rufus (highlighted one was the issue with me as I was using Rufus 3.x version):-

  • Version 4.2 (2023.07.26)
    • Add detection and warning for UEFI revoked bootloaders (including ones revoked through SkuSiPolicy.p7b)
    • Add ZIP64 support, to extract .zip images that are larger than 4 GB
    • Add saving and restoring current drive to/from compressed VHDX image
    • Add saving and restoring current drive to/from compressed FFU (Full Flash Update) image [EXPERIMENTAL]
    • Fix a crash when trying to open Windows ISOs, with the MinGW compiled x86 32-bit version
    • Fix an issue where ISOs that contain a boot image with an ‘EFI’ label are not detected as bootable
    • Increase the ISO → ESP limit for Debian 12 netinst images
    • Ensure that the main partition size is aligned to the cluster size
      so now I have installed Qube OS 4.2.0 RC4 successfully on my machine.

in nut shell, following steps helped me to get fix of this issue:-

  1. Using latest version of Rufus (4.2 or above)
  2. Updating BIOS to its latest version
  3. Verification and usage of corrected Qube OS ISO file

Thanks and Regards

1 Like