[qubes-users] HCL - Dell XPS 9570

HCL reports attached for Qubes 4.04 and 4.1.

Some prior reports report these machines are working - I’ve noted a few caveats to that which may be useful for anyone considering one.

2018 XPS 9570.

  • 4k screen

  • 32gb RAM

  • Samsung 970 Evo


Installer requires mapbs, noexitboot, modprobe.blacklist=nouveau commented out as per UEFI troubleshooting page.

Installation completes fine and system boots, however var/log/Xorg.0.log shows ‘Reverting to software rendering’ even with i915.alpha_support=1. Tried various combinations of drivers and options, no result. Issue detailed here (https://github.com/QubesOS/qubes-issues/issues/5244) indicates this is likely due to fc25 Mesa drivers.

High CPU load, poor performance (input latency).

Upgrade to kernel 5.10 produces significant graphical glitching and does not resolve problem.


Installer boots and completes, system boots out of the box. Wifi, etc all working.

Software rendering issue from 4.0.4 is fixed.

However - I experienced some input and gui lag which seemed to me to be in excess of that I experience on my current Qubes machine - an X1 Carbon 5th running 4.0.4 w/ i3. Attempting to resolve this highlighted a few issues:

Refresh rate in AppVMs

Refresh rate issue mentioned here applies (https://github.com/QubesOS/qubes-issues/issues/3175) - I worked around this by using xrandr to set mode to 2560x1440. I didn’t research Qubes experience with HiDPI screens before purchasing because I’m an idiot.

Intel GPU issues

Journalctl produces the following error in substantial volumes:

“dom0 kernel: [drm:gen8_de_irq_handler.isra.0 [i915]] ERROR Fault errors on pipe A: 0x00000080”

Intel pstate issues

Journalctl --boot reports:
intel_pstate: CPU model not supported

Xenpm can’t retrieve CPU info as per this issue: https://github.com/QubesOS/qubes-issues/issues/4604

modprobe xen_acpi_processor allows xenpm to retrieve info and cpufreq-average indicates scalings is working, but I’m not sure if that information means much - there’s a substantial discussion in the linked issue on the reporting of cpu info - I may be misinterpreting - read it for yourself and reach your own conclusions if you have better understanding of these issues than me.

hypervisor.log shows 6 CPUs identified.

App performance

On both kernels 5.4 and 5.10, in Fedora 32 and 33 templates, and on 2 clean installs, Libreoffice runs extremely poorly - significant performance issues working with an 8 page document (text only). Tried LO 6.4 and 7.1, from RPM and flatpak. Tried clean template installs. No improvement.

MOCS failed to program

Upgraded to Kernel 5.10 to see if any improvement on noted issues. Journalctl produces the msg “Failed to program MOCS register; expect performance issues”. See here for some info: https://github.com/QubesOS/qubes-issues/issues/6397.

5.10 produces significant graphical artefacts on dom0 menus.

I’ve experimented with different driver settings (modesetting, intel, glamor, etc, etc), no impact.

Also tried blacklisting Nouveau on an existing installation and reinstalling with Nouveau blacklisted from installer - no change. On a normal installation system seems to find and default to the uhd 630 anyway.


I feel like this machine as it is doesn’t seem to represent any noticeable performance improvement over my X1 Carbon 5th, which runs Qubes extremely well and without issue. Maybe it’s an issue with my specific hardware - not sure.

Not sure what the cause is of these issues - similar painful experiences to those associated with every other hybrid graphics workstation type laptop in the HCLs. Begs the question of why I thought it was a good use of time to try…

Did give me an opportunity to try the 4.1 alpha though - super impressive. Very excited for the release and upgrade on my X1. If anyone wants an XPS 9570, let me know…


Qubes-HCL-Dell_Inc_-XPS_15_9570-20210226-102904.yml (740 Bytes)

Qubes-HCL-Dell_Inc_-XPS_15_9570-20210225-192445.yml (795 Bytes)

(Attachment Qubes-HCL-Dell_Inc_-XPS_15_9570-20210225-192445.cpio.gz is missing)

Hi Ben,

I could only find one report for this exact machine and that's the report from Jan Fabo [1]. But even then your machines are not 100% the same. Jan's machine runs an older BIOS (v1.5.0) and has an i9-8950HK. But that's about all the difference I could see from the HCLs. It might be worth to contact him and exchange experiences / document them here for others.

I have merged your reports into one HCL (they can contain multiple versions) and submitted a PR [2]. The one from Jan will remain separate because of how the HCL format is structured (if there is any hardware difference it needs to be a separate entry -- makes sense).

Thank you for the report! Happy to read you have a Qubes OS install that works for you ("X1 Carbon 5th running 4.0.4 w/ i3").


[1] https://groups.google.com/g/qubes-users/c/jg2XjhLylc0/m/XKox0B7jCQAJ
[2] add Dell XPS 15 9570 by Ben Moody from 2/25/21 by SvenSemmler · Pull Request #47 · QubesOS/qubes-hcl · GitHub