Qubes suddenly cant boot anymore from external drive

I installed qubes on an external ssd a while ago and everything worked fine until i disconnected and reconnected the drive. When i checked the boot partition the efi folder appears to be empty. What should i do?

to boot from external drive. you should copy the entire qubes folder from /EFI partition to boot folder inside /EFI partition.

normally, if your drive is Internal (using sata, can’t confirm with pcie), uefi is looking for /EFI/qubes.
but for external drive, it should be in /EFI/boot, then recreate uefi entry with efibootmgr command.

since you said EFI partition is empty, are you sure your EFI partition isn’t in other drive ?

1 Like

yeah iam sure. I dont have any internal drives. efi is just empty. How can i fix this ? I used a fedora usb to check

how do you check ?
have you try mount /boot then /boot/efi ?
i’m sure you haven’t mount efi partition if efi is empty.

1 Like

…yeah didnt mount it. I copied all data from /qubes to /boot, then used my qubes installer to go into rescue qubes, skip to shell, created a mount point for the external drive, mounted sda1, cd into the mount point, use the command: efibootmgr -c -l /efi/boot/ grubx64.efi -L qubes -d /dev/sda -p 1, exited.

When it restarted i was able to boot into qubes. But when i removed the usb installer the entry was gone again. Wheres my obvious mistake?

sorry for the late reply

it maybe caused by your motherboard firmware, some need windows loader.

Everything worked fine when i installed in on an internal disk. But i really want to use qubes on an external . What else can i try ? Should i boot into qubes with the usb stick and then try to create the entry there again?

yes you can, it’s just your firmware is overwriting uefi entry.

1 Like

try changing efi and cfg name from /boot/grubx64.efi to /boot/bootx64.efi and /boot/grub.cfg to /boot/bootx64.cfg then recreate uefi entry based on these new name, i wonder if firmware still overwriting this.


Sorry i was offline for a few days so i only got to try it now. It worked thank you very much!

I would kindly ask @51lieal to collect his solutions about booting and installing issues, and to publish it as how-to troubleshooting guide in the appropriate subforum and to regulary update it with new solutions. It would be invaluable resource for novices.
Something like PCI Troubleshooting guide

Thank you so much for your contributions so far.