Qubes OS time is wrong

Hello! My Qubes OS install is setting the date to 2030, the wrong month, and the wrong day.
I cant download qubes OS updates.
I cant install anything in debian 11, hence why even though running sudo systemctl status systemd-timesyncd and understanding that “Unit systemd-timesyncd.service could not be found.” is the output, I cannot run sudo apt install systemd-timesyncd

Any help appreciated.

Update: Output on timedatectl command when run in dom0

System clock syncronized: no
RTC in local TZ: no
NTP Service: inactive

systemd-timesyncd should be installed by default in Fedora templates. what template does your sys-net (i.e. default clock qube) qube use?

sys-net uses debian-11 as a base template. I am not good with fedora

try switching it to Fedora, then you can check systemctl status systemd-timesyncd in sys-net.

So sys-net is a disposable machine. I historically have never been able to get disposables to work when I try to create disposable temples. I created a new qube called sys-nett and its based on fedora. It is a standard app qube. I added the clocksync part in the qubes manager and then changed clock to go to sys-nett

Okay I am getting that it is loaded and enabled. The drop in is /usr/lib/systemd/system/systemd-timesyncd.service

Active: active (running)

Status: Idle

is the time correct in sys-nett? if it is, other qubes should get the correct time at boot time

Time is now working. Now the new goal is to find out why sys-net wasnt working for clock qube. And the second thing is to see if I can restart the entire device and things stay

because systemd-timesyncd isn’t installed in Debian templates by default. if you install it there, restart sys-net and make it the clock qube, everything should work.

i think you’re better off using Fedora for sys-* qubes, since it’s the default and therefore more tested

I do see two issues here:

  1. I am not sure how I would do this. I cannot make new disposable templates as template_for_dispvms never seems to work for me for some reason. And I want sys-net to be disposable. The only way I would be able to do that is if I made fedora the default but this would unfortunately lead to me not being able to make a debian 11 dvm.

  2. Just weird how ive never had this issue before

do you encounter any errors with this:
open Create new qube:
name: fedora-38-dvm
type: AppVM
template: fedora-38
networking: default (sys-firewall)
tick Launch settings after creation and click OK
tab Advanced, tick Disposable template, hit Apply and then OK

after that, you should be able to set the template of sys-net to fedora-38-dvm

I would have to reinstall fedora quickly, In one solution I tried I purposefully de-sanctified my fedora template qube by giving it networking, considering I have qubes installation media next to me and I happen to have just installed this system moments ago.

However, in my other systems, yes this ALWAYS gave me an error.
I couldnt do template_for_dispvms in terminal either

what Qubes version and what error?

I always keep qubes up to date. The error was that template_for_disp_vms did not exist. Or something along the lines of that. There is actually a thread about that exact issue on the forums but those solutions didn’t help me either. @lovemesomesocks5

some people are already using the release candidate for Qubes 4.2, which is why i asked. but i must admit, it’s a really weird error, one that i have never seen

Here is just one of the examples. I am sure there are more.