Qubes OS 2.4.1 Crashes at plymouth-quit-wait.service

It never goes past this point after a fresh installation. What do I do to fix this?

Do you have a dedicated GPU?
Try to switch to another TTY when it’s stuck at plymouth-quit-wait.service using Ctrl+Alt+F2. Will you see console login prompt?
You can try this:

yes I have a RTX 3080 forgot to mention

Just tried didn’t work at all the screen still completely freezes at this point no clue why. This keeps happing after im finished install and past qubes os configuration. It never goes past this point please help

So you were able to boot to this step?

If yes then try this:

How many displays do you have?
How are they connected to your PC?
Do you connect your display to Nvidia or Intel GPU?
Try to connect the display to another GPU.

Yes I was able to boot to this point. After I went to the next point I was never able to boot back into the os. I have 1 display, Display port to rtx 3080

First try to boot with disabled qubes autostart.
If it won’t help then try to connect your display to Intel GPU.

How do I disable auto start?

Doesn’t work at all what so ever. Same exact result

Then try to connect your display to Intel GPU.

It works only if my gpu is not allowed to be able to be used as the main display. But I want it to be used as my main display.

I really rather use 1.4.2 but I cant as I cant get the EFI to show up in the boot menu for what ever reason. My Gigabyte Z390M, sadly its now dead, did with no issue Is it possible you could help with this too?
Its very confusing to me why this for what ever reason happened.

Why do you need Nvidia in dom0?
There is no graphics hardware accelerations available for qubes from GPU in dom0.
So GPU in dom0 only used to output the image received from qubes. GPU won’t render anything inside qubes, the CPU will be used for rendering.
But you can passthrough your Nvidia GPU to some qube and use it there for 3D-accelerated tasks:

The Intel GPU will be more than enough for dom0 tasks. So you can use your Nvidia GPU inside some qube instead.

But if you still want to use Nvidia in dom0 then you can try to check your BIOS settings, try to find some option to set Primary GPU or maybe disable integrated GPU.

You want help with installing Qubes OS 4.1.2?
I don’t think it’s a good idea, the Qubes OS 4.1.2 won’t be supported anymore in June:

I understand but Qubes OS 4.1.2 was always stable for me and always worked normally.
And at least I was able to get 165 hertz on my dom0 but even when I try to use my GPU to display anything it crashes it only works when I make my CPU display things. It feels like this new version is handicapped.
But if this is what is I must admit it sucks. I can push but this is unfortunate.

Did Qubes OS 4.1.2 work for you on your current motherboard MSI Z370M? Or only on your old one Gigabyte Z390M?

Chances are that my problem of not getting a boot menu selection for Qubes OS 4.1.2 is very unique. Im not sure why this is happening what so ever.

Even when I told my SSD from my dead motherboard and plopped it into the replacement motherboard it still showed no boot menu. And Ive tried reinstalling several times now.

It only worked on my old one

Then most probably it’d have the same issue in Qubes OS 4.1.2 as you have with Qubes OS 4.2.1.

You need to manually add EFI boot entry after switching the motherboard for Qubes OS 4.1.2. This issue was fixed in Qubes OS 4.2.1 some time ago.
You can fix your EFI boot issue like this:

I tried that and I still don’t get a boot entry

[shell] : efibootmgr -v -c -u -L “Qubes OS” -l /EFI/qubes/grubx64.efi -d /dev/nvme0n1 -p 1 reboot change -d <which drive?> and -p <which efi partition?>.

The boot entry should’ve been created even if it wouldn’t work.
Did you change /dev/nvme0n1 to your disk?
Did you change the EFI System partition number from 1 to partition number on your disk?
Add the boot entry with efibootmgr command and then check that it was created with this command:


You should be able see the boot entry with the name “Qubes OS” in UEFI boot menu.