Qubes 4.1 Installation Issues for Legion 7

I’ve been trying to install Qubes on my Legion 7 Gen 6 (AMD Ryzen 9 5900HX with RTX 3080) for the past several months now with not much luck. I’ve tried a variety of solutions found on the forum here and some have led to different results.

I’ll try to list everything I’ve done to hopefully provide a clear picture to my problem so this may be a bit long. I have tried using two different 16 gb flashdrives (using Rufus in dd mode) so that could be the issue, however the initial GRUB menu does appear and I have booted other Linux installers from them. I have also been using the newer builds from https://qubes.notset.fr/iso/, I believe I’ve tried probably 7 or 8 of them as well as a Qubes 4.0 image from one of the other mirrors.

The first time I tried to install Qubes, I selected the Install Qubes option from the grub menu and was greeted by a complete black screen. Trying the verbose mode, it went through the verbose boot with the very last line being “Xen is relinquishing vga console”.

I tried adding the “vga=,keep” (I have also tried “vga=current,keep” which I presume does the same thing) and after even more verbose text that appears slowly one line at a time, it then hangs on “[ 512.520643] ACPI: PM: Power Resource [PG00]”. I am not quite sure what this means other than something about the power manager.

After here I tried a variety of other boot arguments found on this forum in the grub, I didn’t keep complete track of every combination I used but here’s a list. Some of them I put on the xen.gz line and some on the second line, as far as I’m aware I was putting them on the correct line.

  • “console=none”
  • “dom0_max_vcpus=1”
  • “dom0_vcpus_pin”
  • “i915.force_probe=*”
  • “nomodeset=0”
  • “i915.alpha_support=1”
  • “iommu=no-igfx”
  • “nouveau.modeset=0”
  • “rd.driver.blacklist=nouveau”
  • “video=vesa:off”
  • “acpi=off”

Both the arguments about dom0 vcpus were needed to not get the same freeze on Power Resource, but would lead to a soft lockup on the CPU, that seemed to loop.

Most of the verbose I couldn’t understand but some parts stood out, all of the below is without using arguments about dom0 vcpus.

“[503.363866] ACPI: BIOS Warning (bug): Incorrect checksum in table…” followed by text that I failed to copy.
“[518.022672] ACPI BIOS Error (bug): Could not resolve symbol(_SB.PCI0.PB2], AE_NOT_FOUND (20210730/dswload2-162
[518.022672] ACPI Error: AE_NOT_FOUND, During name lookup/catalog(20210730/psobject-220)
[518.022672] ACPI: Skipping parse of AML opcode: OpcodeName unavailable (0x0010)
[518.022672] ACPI: 18 ACPI AML tables successfully aquired and loaded
[518.022672] ACPI: [Firmware Bug: BIOS _OSI(Linux) query ignored”

Any suggestions for what to try would be appreciated and let me know if any other specific information would be helpful.

1 Like

After trying the second release of Qubes 4.2 on https://qubes.notset.fr/iso. I managed it get it installed. I used the boot arguments:

  • console=none
  • vga=,keep
  • dom0_max_vcpus=1
  • dom0_vcpus_pin
  • acpi=off
  • nomodeset=0

Everything seems to be working as expected. I won’t be using Qubes for anything too important until a proper release of Qubes 4.2 comes out but I’ll post any other issues and fixes I find on here for anyone facing similar issues.

Hi there - i too am fighting my Legion 7 attempting to get it to install and boot from USB drives.

Could I ask :

  • Second Release : is that the 8th March one in that long list? (did subsequent releases not work for some reason?)
  • I’m assuming those boot arguments are required for a successful install? - i’ve attempted to boot with latest kernal and I can progress through install screens but when it comes to -actually- install it took…maybe 6/7 hours gently trickling along before it eventually crashed out.

(i’m assuming, but I welcome being corrected, that the acutely painful slow install time indicates that it’s borked?)

Any other advice on making the Legion 7 work with Qubes would be gratefully welcome.