Cannot install QubesOS, always booting to a black screen

This leaves me with more questions than answers :frowning:


in the boot command line of xen
Edit(1) (me) no clue

in grub

(me) I am guessing by editing the file:

sudo mousepad /etc/default/grub

I should add:


In which/to which line should I add it?

Should the last step be:

sudo update-grub

Edit(1) Or is it the files in the “USB stick”

Thanks for the reply :smiley:

Example with images, but this one is not for Xen command like options:

1 Like

…Scroll down with arrow keys, and find the line beginning with “multiboot2”, and add x2apic=false to the end of that line…

I do not have a line that starts with :frowning:


Edit (1)
I’ve not installed or was ever able to install Qubes at all :frowning:

You need to edit the grub options for Qubes OS installer, not your another OS grub.

Thanks, that I understood better.

Still, nothing but a black screens :frowning:

You can try this:

Thank you. I tried:



I also tried for “Install Qubes (not the latest kernel)” with no success :frowning:

This is far away from easy for my hardware :frowning: !!

I booted with the verbose mode and could get these screenshots from videos I captured.
It happens so quickly, and goes to a black screen, so I could not get a log of what happened :frowning:

Thie first image is the first details I get, which I do not think is that important!

These two images are of the last messages I get.

Can anyone give any tips into what’s going on?

You need to add dom0_max_vcpus=1 and dom0_vcpus_pin to Xen command line parameters (multiboot2 line in grub).
acpi=off and nomodeset should be added to kernel command line parameters (module2 vmlinuz line).
You can also remove quiet to see the log output.

1 Like

I tried everything as you posted, nothing worked :cry:
I tried that for Install Qubes, Install with latest kernel, Test media…

:frowning: anyone has any tips!

Thank you in advance :slight_smile:

Some progress:

Qubes release 4.1.2

  1. Remove all SSDs, and leave just one for Qubes OS. Such that when I boot, I’ll only have the SD card & one SSD on the system.

  2. Use USB 2.0

  3. 16GB SD Card

  4. The SSD that I used had one partition and it was “unlocated/empty”

  • a.1) lsblk “or lsblk -f for more details”

  • a.2) Find your SSD: min was: sda, yours could be sdb, sdc, …

  • b.1) Format it with the commands: mkfs.ext4 /dev/sda

  • b.2) Change “/dev/sda” with - a.2)

4.1. (still not 100% sure about the following)

4.2. When everything is ready, and after a restart, when booting, … mash F8 to get to the boot selection menu. Do not select:

UEFI: “Your SD Card”

UEFI: “Your SD Card - Partition 2”

and select:

“Your SD Card”

4.3. Press the “TAB” button when selecting “Install QubeOS” and add as @apparatus :hugs: suggested

dom0_max_vcpus=1 and dom0_vcpus_pin to Xen command line parameters (multiboot2 line in grub)


acpi=off and nomodeset=0 should be added to kernel command line parameters (module2 vmlinuz line).

My installation now came to a close after the following message:

The following error occurred while installing the boot loader. The system will not be bootable. Would you like to ignore this and continue with installation?

Failed to set new efi boot target. This is most likely a kernel or firmware bug.

I’ll give Qubes release 4.2.0-rc5 a try, and see what happens. I am very glad that I got over a lot of hurdles, I am happy and wanted to share what I’ve been through. I am also past the black screen of the abyss.

Should be some Fedora bug and not related to Qubes OS specifically.
You can search for a fix here:

1 Like

I tried Qubes release 4.2.0-rc5 and found whay I have the black screen of the abyss :smiley:

  1. Boot & select USB “not the UEFI partition”
    on the xen.gz line I added:
    on the vmlinuz line I added:

    I get this:

    This is what I get:

Xen hypervisor allocated kernel memory conflicts with E820 map
(XEN) Hardware Dom0 halted: halting machine.

  1. I tried:
    Boot & select USB “not the UEFI partition”
    on the xen.gz line I added:
    on the vmlinuz line I added:
    I added nothing in this line

  2. I tried:
    Boot & select the UEFI partition in the USB
    on the xen.gz line I added:
    on the vmlinuz line I added:
    I added nothing in this line

Basically, the same!

I just wanted to report this. Still have not found a solution for the error in post #13 :frowning:

Not a single solution was of any help! And most solutions are quarter and half explained :frowning:
I’ve been trying for 3 days now :cry:

  1. While installing:

  2. This is hwo the disk looks like after that installation:

After I unplug all external storage except for the SSD where I installed
Qubes OS, when I (F8 to get the boot menu), there is no UEFI partition! Is that normal?

  1. My boot menu:

  2. Reboot and select proper Boot device
    or Insert Boot Media in selected Boot device and press a key

  3. When I boot from from my Manjaro’s disk, I get:

  4. Which gives me:

  5. Advanced options for Qubes “from the 5. step” gives me these two:

  6. Both of which gave the same error, a similar one to the one above:

  7. Grub for Qube “not from the Advanced options for Qube (5th image)”

  8. Grub for the first of two, from “Advance Options” “from the 5. step”

  9. Grub for the second of two, from “Advance Options” “from the 5. step”

My brain is cooked. I really wanted to run this OS :frowning: I am heart broken.
I bought this used monster of a PC just because I wanted this Distro.
Will not give up :angry:

I also looked at:

step 2.

cd /mnt/sysimage/boot/efi/EFI/qubes
cp xen-*.efi xen.efi

Copy them where to?

Step 3. Create xen.cfg
An aditinal tip would be:
tocuh xen.cfg
nano notwor for me to edt, so I used:
vi xen.cfg

Btw, all of that was not necessary, because there were no problems with these files as I checked :cry:

It’s outdated.
To fix missing UEFI entry you need to do this:

Also the Qubes OS 4.2 is released so it’s better to install it instead of Qubes OS 4.1.2.

1 Like

I did try that too, but got an “error” that I could not solve! I wrote my last post at 3 in the morning :sweat_smile: sorry, I forgot to say/add that!

A side note:
Something that I noticed after the install, there is no UEFI partition
with SATA6G_5: Crucial…!

But, let’s first talk about:
efibootmgr -v -c -u -L "Qubes OS" -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1

The only way that I can access and install “unsuccessfully” is by:
Select the:
UEFI: SanDisk (15.3GB)image above

I then get a quick flash of
Welcome to GRUB:

I select:
Install Qubes OS R4.1.2.0 using kernel-latest …

press e to edit

on the xen.gz line I add:

on the vmlinuz line I added:

When I get the “installation screen”, I press:
Ctrl + Alt + F2

then the following image:


I have a typo here!
it should be:
efibootmgr -v -c -u -L "Qubes OS" -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1
That still did not fix the issue!

Boot0002* Hard Drive
and is where I had installed Qubes OS

Boot0003* UEFI: SanDisk
Boot0004* UEFI: SanDisk, Partition2
and is what I use to install the OS:
lsblk -p
sudo dd if=Qubes-R4.1.2-x86_64.iso of=/dev/sdb status=progress bs=1048576 conv=fsync
Taken from:

Boot0005* USB

Boot0006* UEFI: Generic-USB3.0...
and is where I had Qubes-R4.2.0-x86_64 (I have installed 4.1.2, this is the new version!)

efibootmgr -v -c -u -L "Qubes OS" -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1
Could not prepare Boot variable: No such file or directory
Do I have to
mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1

I also tried installing 4.2.0. At the moment, I found not a single way to reach the
installation screen.
I’ll try to use another SD card and format it as fat32

Try to add x2apic=false in the boot command line of xen in grub as well.

Maybe there is no such file /EFI/qubes/grubx64.efi in EFI System partition for some reason?
Try to mount the EFI System partition and check the files there:

mkdir /mnt/sda1
mount /dev/sda1 /mnt/sda1
ls /mnt/sda1/EFI/*
1 Like

Here is what I did:
I see that there are the necessary files after mounting sda

I have 6 images of grub.cfg, I wont post them unless you think I should.
I looked however at the content of xen.cfg

Which seems correct for me!

And here are som more stuff that I tried to look at and some changes that I tried
(“Qubese OS” vs ‘Qubes OS’ in:
efibootmgr -v -c -u -L "Qubes OS" -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1 ):

I’ll do that next for Qubes OS 4.2.0 :slight_smile:
sudo dd if=Qubes-R4.2.0-x86_64.iso of=/dev/sdZZ status=progress bs=1048576 conv=fsync
Thank you very much for all the help so far by the way :slight_smile: :hugs:

The doc is outdated and xen.cfg is not used by default anymore so you can remove it.

Try to boot the installer in rescue mode without acpi=off and other options that you were adding and run efibootmgr again.

1 Like

WOOOOOOOOW, MASSIVE PROGRESS NOW :partying_face: :smiley:

I tried without any commands => Got a black screen

Tried with onle:


Ctrl + Alt + F2

efibootmgr -v -c -u -L "Qubes OS" -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1

Worked! :smiley:

Then selected the first choise:

Got past this:

Then, no mouse or keyboard:

I left everything as default, but at the end I got:

On the firts start of the OS, I got some similar warnings to the following, but I could not snap a photo of them! However, when I tried to launch a Qube, I got:

Another Qube:


I thought that a restart would maybe do the job! It did not! I got the previous warnings “in the two images above” when I tried to launch Qubes before the restart. After the restart, nothing launches still & no warnings!

The System’s settings were accessible, no Qube is “launchable”.

  • I had only one screen resolution (I have an NVIDIA Quadro 4000

  • No network card (I am not connected with a cable, I have a WiFi 6 card, connected to the motherboar on a PCIe slot:
    PCE-AC56 2x2 802.11ac Wifi AC1300 PCIe Adapter

  • When I restart, my wireless keyboard & mouse are not recognised! I have to unplug them and plug them in again. No guarantees still that they will work, so I have to restart again!

I forgot to find the file:
I’ll edit the post and add it here if it is still there!


libxl-driver.log is empty :frowning:

I have Manjaro on one drive, and Qubes installed on another.
When I connected both, I got:
No drive to boot from!

I need to try to install 4.2 :frowning:
Or try to reinstall 4.1.2 and see if I get the same error! :frowning_face:

This is a long journey, still, felt unbelievably happy when I got to see the desktop :smiling_face_with_three_hearts: :partying_face:
Thakn you @apparatus :hugs: would never have come so long without you :smiling_face_with_three_hearts: