Qubes 4.1 installation failure

Did you changed template selection earlier during installation (here)? If not, something went wrong at that stage, can you search for “qubes-template” in /var/log/anaconda and share logs that you find this way?

I reinstalled qubes and took some photos:
There is no option to select any templates

After clicking on ‘finish configuration’ I get

Here are all the logs of /var/log/anaconda (https://easyupload.io/315ben)
Is there a better way to share logs?

I don’t see a stage where templates are copied into the system. On successful install program.log contains near the end lines like this:

18:16:35,505 INF program: Running... /bin/sh /tmp/ks-script-nl7cqm5_
18:17:20,171 INF program: Unable to detect release version (use '--releasever' to specify release version)
18:17:20,174 INF program: Adding repo from: file:///tmp/installer.repo
18:17:20,174 INF program: Unable to detect release version (use '--releasever' to specify release version)
18:17:20,174 INF program: anaconda                                         36 MB/s | 1.1 MB     00:00
18:17:20,174 DBG program: Return code: 0

But I don’t see those in your logs. In a later version this output is saved to one of ks-script-*.log files, but it isn’t there neither in your install.
Honestly I have no idea what went wrong. I don’t see any relevant error message, installer simply skipped that step for some reason.

As for sharing logs, not sure. @deeplow is there any way to attach files directly here?

Is there a way to manually start the installation script (and get a proper log)? I am able to login but there exists only the Dom0 qube in the qube manager.

Edit: I installed it aigan and chose ‘Do not configure anything’. -> No error. But how do I configure the qubes? I just need the default settings.

1 Like

Are you using custom partitions layout?

No, I wiped out a whole ssd. But there is another ssd running ubuntu as dualboot.

Is it possible that my multi gpu setup is breaking this?

Would it be helpful to reinstall in verbose mode and share the logs?

You can check notably if in tmux session panes (CTRL-ALT-F1 or F2 if I remember correctly then you can switch tmux panes) there is issue at the end of the install process before reboot. Specifically it’s during post-script phase and you could check for what’s done for templates: https://github.com/QubesOS/qubes-anaconda/blob/master/30-qubes-templates.ks.

That did it!
There were already files in /mnt/sysimage/var/lib/qubes/template-packages

So i just excuted
dnf config-manager --add-repo /tmp/installer.repo
dnf download --downloaddir=/mnt/sysimage/var/lib/qubes/template-packages qubes-template-*

And now it’s fine:) Thank you!
Is this now a valid installation? What issues could arise now?

Were files already here before you executed the commands? Because if files were already here it’s the expected behavior. In a normal install you don’t need to do that manually of course.

Yes, files were there but I think the repo was not added.

Files are here because of repo setup and dnf download from it. Do you have templates shown at the firstboot screen now ? If yes, can you retry the same without any manual procedure please?

On first boot I was able to select templates like here (https://openqa.qubes-os.org/tests/14363#step/firstboot/5). And now it seems fine. But if I didn’t add repo then it fails.

Honestly, I don’t see what’s wrong as I cannot reproduce it. If qubes-template-*.rpm files where in /mnt/sysimage/var/lib/qubes/template-packages, this is because a local repository has been added into anaconda running system. So there should be no consequence to add the repository again and downloading templates rpm again into freshly created /mnt/sysimage root system.

yes, there is. Currently enabled for .yaml files (for the HCLs). but we can add more file extensions. Which ones would be need? .log (not that file extensions mean a lot. Just the way discourse settings work). I’ll talk to the other mods.

@marmarek users should now be able to attach .log files by dragging and dropping.

I could reproduce this error

I changed the installation media.
I doublechecked the old one.
I could verfiy the problem by test the installation media through the test and install option from the first bootscreen of the media: it said test failed and had this issue with broken VMs.
on the other media the test passed successfully and installation proceed without issues.
its not hosthardware related, because i had the issue on different computers.

I am now getting the same error on Qubes 4.2… I am reinstalling currently to try out the solutions mentioned above, will update here soon.

I have had the same issue now.
I waited for install to complete (got to where it asked me to reboot system now), then I switched to the terminal and tried checking for files in /var/lib/qubes/template-packages, but there was no template-packages folder at all. I figured I would try to do the steps that were mentioned previously, by running:
dnf config-manager --add-repo /tmp/installer.repo
dnf download --downloaddir=/mnt/sysimage/var/lib/qubes/template-packages qubes-template-*

This hung on a screen that seemed to be a download screen (see below)

After this (while it was still hanging, wasn’t sure if it was doing anything or not), I tried to quit to go to the reboot button but I wasn’t sure how, so I rebooted the system. After this, it brought me to the configuration part like usual, but whonix was not available, just like my last attempt:

Any pointer on where to go from here? I don’t really know what to do – if there are logs that I can provide, please let me know. I’m not very familiar with Qubes nor Anaconda.

UPDATE: I downgraded to 4.1.2 and the system works fine for me. Not sure why