Qubes 4.1 doesn't start after installation on USB disk

Hello everybody!

I’m using Qubes OS since 2017 and installed it since the begin, on a SanDisk Extreme Pro 3.1 256gb and I never had problems. I was able to run Qubes on different laptops (Lenovo ThinkPad, Asus ROG, etc.)

Yesterday, I decided to install the new version (4.1) and I got one problem. The installation is fine but then it is impossible to boot on Qubes OS. In fact, I bought a new laptop almost 2 months ago : a MSI GF63 with Windows 11 installed. I tried to search in the bios where is the problem, I tried to deactivate secure boot, fast boot, I put the bios in Legacy mode, but nothing. Qubes OS just doesn’t want to start.

Any solutions ? Thanks in advance!

These seem relevant:

Thanks for your answer.
For some reasons, yesterday I managed to install Qubes on my USB disk and to launch it. I don’t remember exactly what settings I did in the bios…
But today, when I wanted to launch it, impossible. I set up the bios in legacy mode, deactivate secure boot and fast boot but again, Qubes doesn’t want to start…