Qube Menu Apps or Templates nothing opens?

Have you tried some ideas of this page : App menu shortcut troubleshooting | Qubes OS ?

Couldn’t it be related to this strange thing about users? I believe that the qvm-appmenus commands need to be run with the correct user.

It seems to me that what you did with users is quite unorthodox and starting from a fresh install could be a good idea anyway.

1 Like

Well what’s strange is I haven’t limited any users yet, because the 1 solution given to me so far seemed very daunting so I was putting it off until maybe after I figured out the network ports and all that

Okay yeah let me check out your suggestion, thanks I hope this helps me find how to restore what went missing

:hugs: thanks so much

Just tried,

In dom0, run

qvm-sync-appmenus <templateName>

This was the output:

Had an error,
“line 377, in retrieve_appmenus_templates raise qubesadmin.exc.QubesVMNotRunningError”




check it out
(okay so I figured out I needed to launch the template then run the command lol)

The Qubes developers are world-class experts in virtualization security. They created Qubes OS to be a secure hypervisor-based OS. Meanwhile, you describe yourself as having little-to-no knowledge about Linux or virtualization (which is fine). But then why think you can make Qubes OS more secure by copying commands from random Internet strangers? Why does that seem likely to produce the desired outcome?

There are many OSes to choose from. Why choose Qubes in the first place if you believe it’s not secure enough for your needs out of the box? Wouldn’t it make more sense to choose whichever OS you perceive to be a better fit for your situation?

Also, why assume that the hypervisor “is stock and default all over”? Does it not seem plausible that the Qubes developers might have modified Xen in the process of using it to make Qubes?

More broadly, why equate “stock and default” with a lack of security, especially in the context of security software, which is supposed to ship with secure defaults?


Because basic stuff like separating the admin from the user isn’t available to do in the GUI, or place a password on SuDo is not available in the GUI and I want these both for my mom and my own laptop so we can use a user that NEVER enters a SuDo / ROOT passphrase in case the virtualization gets broken hopefully the separating of the admin activities stumbles them

I know this is useful, so long as separated properly but Qubes out of the box doesn’t offer it and I know I need it for the Threat Model I and family members are now under. So I might not know enough HOW to do it but I know I need it so I will look to try my best to implement it.

Sadly I hear there are advanced methods to also harden the Kernel but I know my limits and I know nothing about that so I will not even try.

I don’t think it is too much to try to separate user login and user activities though, which Qubes do in VMs I am just taking it one step further since it isn’t offered in the GUI yet

Excuse me lol Qubes is IMHO as good as it gets but it still needs improvements even stated by others who know more than me in this Forum lol I aint down grading just because Qubes isn’t perfect that’s ridiculous

Don’t misconstrue what I am begging for. I never said they weren’t secure. I expressed it wasn’t enough for my new Threat Model which I am not happy about being under.

Also, the vendor literally dumped the first version of the BIOS on my laptop I am extremely upset I have to now figure out how to update the UEFI, that has nothing to do with Qubes btw

AND everything is back in the Manager TOO



check it out:

Once I added more apps inside the Manager I didn’t realize I would have to run the command again to make the new ones appear, but I figured that out at least

Still not seeing my USB external drive in anyway even with these file manager app package thingies installed, and I did put sys-usb in there at the start so not sure what is going on with that

There was a button in the “Applications” tab of a qube, you didn’t try to click on “Sync menus”?

1 Like

I didn’t see or notice it, and even if I did I had no idea what “sync applications” was until after doing all this now I know what it is so if I ever see it in the GUI then I would now be likely to click it

I don’t remember noticing it, doesn’t mean it wasn’t there — just didn’t notice it

Something you wrote in your very first post on this thread indicated you were calling up “start qube” and expecting something to open. (Then you pursued other issues here; I’m glad you got them resolved!)

Start qube in the menu simply starts (boots) the qube, it doesn’t start any application IN the qube (and that includes not starting up a file manager or terminal). You have to explicitly select one of those (and you might need to add them in the applications tab you’ve been looking at, for them to show on the Qubes menu). So to see a file manager pop up when you start a qube–select the file manager, not start qube.

If you have a disposable (the kind that fires up a qube named something like disp1234) start qube won’t do anything at all; those disposables shut down as soon as they’re done running the command you gave them on start up. When all you’re telling it to do is start up, it has nothing to do and immediately shuts down (if it starts at all). On those qubes you must select an actual application (and when you close that application the qube will shut down).

1 Like

I been wondering about that. I haven’t made a disposable yet, but will soon … and also I been wondering where to find the documentation on how to promp disposables to open from another VM. Like say I have a VM to see files but not open them, can I on click have the app like a PDF reader open in a disposable and not the current VM but how I have no idea but I heard this is a thing in Qubes to do and I would like to do that

Thank you btw

That gets one into tricky policy stuff.

I’ve managed to get links in emails to open in a disposable just by clicking on them (it prompts me first), but I’ve never gotten email attachments to open in a disposable; I have to right click and send them there. If I don’t right click the email qube simply asks me what app I want to use to open the attachment (and since I deliberately didn’t install Libreoffice or any sort of imaging program on my email VM, there’s no suitable attachment most of the time). It’s probably something I broke.

1 Like

Darn it!

This is exactly what my mom will need

I guess I could try to make my mom remember to right-click by leave out the PDF reader and LibreOffice apps … forcing her to remember to right-click hopefully

Actually I am investigating this.

The attachment must be saved.

Then, I am able to go into the file manager, right click, and say “Edit in DisposableVM.” That works. It’s easier than having to copy the file to a named disposable then open it. Provided your mom can remember to save and go to a file manager, that’s good to go.

It’s “Open in VM” that won’t work for some reason; it’s throwing a policy error. (Which is crazy since the policy is actually named OpenInVM, but it seems to actually control “Edit in DisposableVM” as well. That works, Open in VM won’t. WTF?)

[Edit: I’ve started another thread about this.]

1 Like

will try that and more when I get back there