Qube Menu Apps or Templates nothing opens?

I click the Q menu, and wether I go to Apps or Templates and click to “open” a qube. It launches according to the pop-up saying the qube is running, but I see absolutely no windows of any kind like I saw in the YouTube tutorials

Where are these running qubes if not appearing as little windows as advertised in tutorials?

I just closed the Vault Qube and thouht it would open a file directory type of window but nothing appears, nothing appears for any of the defaults I clicked on let alone the new cloned qube

I am confused as to what is happening

why are no windows in the color yellow, red, blue, gray, or black appearing. Nothing seems to happen except the notification alerts saying it is running

says application missing from template

but the left box is empty while this box on the right has four items all have a warning “application missing in template” but why and how

I don’t get it

“qubes-windows-tools” is not installed in dom0

Does this mean this OS doesn’t have basic stuff installed, like I have to actually put it online and do command lines just to install GUI windows to see a file folder … what

wow (not a good wow) … I just want a file window

This is useless to me, it says “Files” but the “apt” apparently isn’t called “Files”


as ROOT:

apt install Files

I can’t believe nothing is installed in the basic Qubes OS what …

What is it even called then, what package is going to make me have a GUI view of folders and files geez this is such a basic necessity for people who hate CLI how is this so much to ask for why is this not pre-loaded omg

I am going hungry without money for food the longer I remain not up and running back online yall, please help


Figured this might work since there is Debian in common, but guess not

Well … It’s a bit confusing, could you tell us more about the VM, the template used, if you installed something in the template ? Did you refresh the application list, what’s available ?

Not answers but some notes:

  • I think qubes-windows-tools has nothing to do with a window manager, it’s was about Windows OS ?
  • apt is used on debian systems
  • dom0 is based on fedora, not debian
  • don’t install anything in dom0 without knowing what you’re doing
1 Like

Did it work before?

looks like your did something to your template

1 Like

Xen Windows Tools unfortunately had a major vulnerability a few months ago, and its builds were removed from both mainline Xen and Qubes OS, for fear that someone might be compromised by an attacker exploiting the vulnerable Windows drivers.

The 4.1.70-1 version of qubes-windows-tools was replaced with an empty package with some information about what had happened.

1 Like

as ROOT:

apt install Files

Figured this might work since there is Debian in common, but guess not.

Couple of things (which were already mentioned by @parulin):

  1. Do not install software in dom0. Do not use package management commands outside of VMs unless absolutely necessary.
  2. dom0 is based on Fedora Linux, which is not Debian Linux, and therefore does not use dpkg and apt for package management. There are special ways to update your Qubes OS system and install templates (use qvm-template-gui).

What is it even called then, what package is going to make me have a GUI view of folders and files geez this is such a basic necessity for people who hate CLI how is this so much to ask for why is this not pre-loaded omg

A graphical file manager is already installed in both dom0 and non-minimal templates. By default, it is called by the generic name “Files”, but that is simply an user-facing name to use in menus such as application launchers. The actual name of the XFCE file manager is thunar, and you can write thunar in the terminal to open the application.

Additionally, please be more respectful and don’t assume things before fully understanding them.

1 Like

It’s called Files, and it’s installed by default in the debian-12

apt is a package manager used to install packages on your system. It
has nothing to do with a GUI file manager.
You could use aptitude instead of apt which provides a basic GUI application.

That’s why “Files” is installed in the standard template.
If you dont have this then either:
a) You removed the package, or
b) You are using a minimal template.

The fact that you see those “application missing in template” entries
makes me think it is (b). Since you havent said what template you are
using, or what you have done to your system, I’ll stick with that.
Using a minimal template is wholly unsuitable for a beginner. Dont do

The best way for you to proceed is to do a clean install of Qubes: do
not tinker with it - use it as it is installed.

You have said you have little experience in Linux, and do not have time to
read or research the issues. The safest thing for you to do is to use
the system as it is installed.
Unless the options are covered in the official docs, or are discussed
by a team member, you are simply going to be copying stuff from random
people on the internet without understanding what you are doing.
Do you think that will increase the security of your system?
Will it make you safer?
Will it make you feel safer?


No - it doe not.
qubes-windows-tools is a package that provided tools for installation
in to Windows OS qubes.
The default templates come with GUI file managers installed.


1 Like

I didn’t touch this at all, all I was doing was setting up users and stuff yall saw before.

Now that I am on this step, I finally clicked the Templates and Apps in the Q drop down and everything is blank except at the bottom where it says to launch the qube

I even tried launching the qube template then going to the app template and clicking that

I went back into the Manager and it has nothing listed on the left hand side like all the YouTube tutorials have but it does have those 3 or 4 on the right hand side all of with has the exclamation warning of it not existing for whatever unexplained reason

The only reason I know it works is before and even know when I click on “info” about dialog hyperlinks it tries to open Firefox in a disposable and does (obviously Firefox cannot connect to the internet though)

So Firefox certainly exists yet in the pre-made personal and work qubes it says it doesn’t, and in any new qube I try to make it says it doesn’t exist

So then I saw “Switched to Linux” on his tutorial run a “alt install” command but like other than Firefox I don’t know the names here; but get this it gave the same error when I typed in Firefox. So I have no idea where these Packages are in the OS or what these install files are called other than Firefox


Okay well I al reading through this thread right now just woke up, replied to you question but haven’t read through all replies yet so brb

Okay this seems helpful, turning back on my laptop and will try this but also send more contact since I am sure it is not a minimum qube

It is all of them all the defaults, personal, work, vault etc even the ones I try to make all of them show nothing and pop up nothing when they run

(and no, I didn’t delete anything except for when I removed a user and added a new user a while back)

but okay brb thank you so much the info you gave will likely start to help me but let me go try and see brb

What is “setting up users” and “stuff”?

1 Like

My bad, the other 2 people were helping me so I was referring back to threads that they saw me do before hand. I made 2 user accounts on the same machine, I deleted the original 1000 user after messing it up by trying to rename it only to then remake the 1000 user again — that is what I mean by “and stuff”

Okay this is what I am seeing:

No applications found.
You can add them using Settings

On the machine I been working on

On the other machine that has remained untouched this is what I see:

I hover over Vault and in the next column the apps appear as Firefox, Settings Manager, and Xfce Terminal — all as expected!

Which shows applications when I hover over the “apps” drop down in the Q of Qubes’ drop down menu.

So now I am worried, when I deleted the original “star” user, even though I created a new one and put itself UID and GID and all that to 1000, did it mess something up?
I did recently decided to delete the 0 LUKS slot and now I have a LUKS key only in 2 other higher count places

Did any of those changes mess with the preinstalled default package apps???

Awwww darn it I was trying to avoid this …

But can you guess what the cause was?
Was it me deleting the original installed user “star” after I messed up its file directory? I had to delete it and redo the entire user, and I was lucky I had already made a 2nd admin account with “wheel” and “qubes” group enabled in it or I would have been SOLed
But maybe I am still SOLed?
You think I should reinstall

That is the only time I remember deleting anything was when I went to thoroughly delete that previous user

Other than that, I don’t know how I may have ended up here as I never did figure out how to restrict the 2nd user and was putting off the long complicated instructions on how to set the SuDo password prompt

I mean, I would rather try than leave it as is because my attacker might know how to break through a hypervisor if it is stock and default all over. I want to at least try to layer up a little bit more, especially anything that would prevent him breaking through a qube or more likely prevent him from infecting any base templates that are used to make templates and/or be the base for disposables after that I want to make sure if he break through mostly everything to try to at least try to guard the BIOS/UEFI boot to prevent any persistence there too as a last ditch effort

Which is why I been trying to do all this stuff

But now it seems something wiped out all the template’s apps

I think what I will do before re-installing is try the same steps on the other laptop, except skip the mess ups. That way if this reproduces the same result I will know it is from that rather than when K deleted a user and its keyslot.

I really don’t want to use Qubes as is, it could be just slightly more secure in certain areas and I am attempting to try

I am worried as my attacker was able to break through AT&T’s ARMOR as well as MacOS firewall and even corrupt its boot etc, so I fear he likely knows or has exploits that would test Qubes’ default hardness as well and I don’t have the $ left to keep finding out how advanced his methods are or are not by sacrificing anymore devices to such malware spyware

what templates do you have installed? It’s possible to reinstall them IIRC with qvm-template reinstall TEMPLATE_NAME

1 Like

But the Templates are showing the same

All empty

“No applications found.”

(on the laptop I been working on, the other laptop seems fine; that laptop has a different BIOS than this 1 and I haven’t done any work other than finishing the install on the other so the other is thankfully not messed up like this one … I fear it was from me deleting that user with the messed up path or something)

How do I get all the default applications back???
(without reinstalling — although I am tempted now to just reinstall)