Qualcomm Atheros Ethernet Connection Issue

Hi All,

Just trying out Qubes for the first time and having some issues with my internet connection.

Using ethernet and the adapter is being detected. I’ve got the ethernet adapter device connected to sys-net and strict reset configured.

The network icon on the toolbar at the top right detects the adapter and shows a wired connection available, but then just shows that its connecting (spinning red icon), and then gives a “connection disconnected” error.

Looking at sys-net specifically in the terminal I’ve used dmesg to take a look at what’s going on. At the end of the output this line is repeated multiple times:

alx 0000:00:06.0 ens6: NIC Up: 1 Gbps Full

Scrolling up further the only thing of interest I can see is the following:

alx 0000:00:06.0 eth0: [name of my ethernet adapter] Ethernet [a mac address]
alx 0000:00:06.0 ens6: renamed from eth0
Error: Driver ‘pcspkr’ is already registered, aborting . . .

Does anyone know what the issue is here, or what more information can I provide to assist with locating the issue?

Edit: Just enabled the wifi adapter and internet works fine via wifi, so seems to be an issue with the ethernet adapter.


1 Like

Hi @smb55, welcome to the Community!

It seems indeed like not a Qubes-specific problem. Sys-net works more or less like an ordinary Fedora with the ethernet hardware. You should be able to find information about your problem on the Fedora (or general Linux) forums.

Some people read this forum via email and do not receive any edits done after 10 minutes. For this reason, it would be better to make a new post next tmie.

By the way, would it be possible that you attach an HCL report for your hardware, to help other users?

Thanks for the reply. My sys-net is Debian, rather than Fedora. Was this something I selected during install? Either way it doesn’t matter. Currently just getting a Debian live USB to boot from to see if I get the same issues on another Debian instance.

In the mean time, here’s some more info in case anyone has any ideas:

lspci returns:

user@sys-net:~$ sudo lspci
00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II]
00:01.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
00:02.0 Unassigned class [ff80]: XenSource, Inc. Xen Platform Device (rev 01)
00:04.0 VGA compatible controller: Device 1234:1111 (rev 02)
00:05.0 USB controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 10)
00:06.0 Ethernet controller: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller (rev 10)
00:07.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

This shows the ethernet controller and all looks fine to me.

ifconfig returns (for the ethernet interface):

ens6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 fe80::786:63ea:7c7d:60d9 prefixlen 64 scopeid 0x20
ether 80:fa:5b:47:8c:5b txqueuelen 1000 (Ethernet)
RX packets 7730 bytes 584770 (571.0 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 48 bytes 4320 (4.2 KiB)
TX errors 0 dropped

Again, all looks fine other than the fact it hasn’t received an IP.

As a new user I’m unable to upload attachments, however here is the HCL report as text:

brand: |
model: |
bios: |
cpu: |
Intel(R) Core™ i7-7700K CPU @ 4.20GHz
cpu-short: |
chipset: |
Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:591f] (rev 05)
chipset-short: |
gpu: |
NVIDIA Corporation GP106BM [GeForce GTX 1060 Mobile 6GB] [10de:1c60] (rev a1) (prog-if 00 [VGA controller])
gpu-short: |
network: |
Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller [1969:e0a1] (rev 10)
Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
memory: |
scsi: |
ST1000LM048-2E71 Rev: SDM1
Crucial_CT275MX3 Rev: R040
usb: |

  • works:
    qubes: |
    xen: |
    kernel: |
    remark: |
    credit: |
    link: |

If I get the same issue on another Debian instance then I’ll start a thread on the Debian forums instead. I did have Ubuntu running on this machine directly prior to switching to Qubes, so not confident its a Debian issue yet.

1 Like

Yes, there was a tick for that. You can change the template of sys-net now and try to use Fedora instead. It might solve your issue, if, e.g., the firmware in Fedora is more suitable.

Thank you! @Sven your turn to include it to the main list.

Thanks, that’s a great idea, will try a fresh install with Fedora.

There is no need to reinstall. You can change the current template right in the Qube Manager, which you can start from Qubes Domains widget.

1 Like

So tested a few things. First live booted a Debian from USB, ethernet connection worked fine right away.

Went back to Qubes and switched the template to Fedora. Now the VM won’t start, gives an error saying unable to connect to the VM. Created a new VM and copied all of the settings from the original sys-net, except used the Fedora template. This VM has a similar problem to the original sys-net. Again, it seems to detect the network adapter fine, however does not make a connection or get an IP address.

Since the Debian live boot worked fine it seems this is a Qubes issue. I feel like it must be some simple settings mistake that I’ve made.

I have two network cards - one is working and the other is behaving like you described it.

2.5 Giga Ethernet Network - Intel I225-V - no problems at all.
10 Giga Ethernet Network - Aquantia AQCC113CS NBase-T/IEEE 802.3BZ - no connection at all.

The Qubes Template: Fedora 38 - Sys-net Kernel 6.5.8-1 Mode HVM
Memory 2000 MB

You can try adding pci=nomsi to the sys-net’s kernel options (see qvm-prefs tool).

1 Like

Try to set Link negotiation to Ignore, or when Manually is set, you should try 100Mbps. Setting to Automatic will most probably result in failed connection, at least on my side.

This fixed it! Thankyou!

what is this exactly?

The command in the Github issue linked that fixed it for me disables MSI interrupts for the system. Why that fixes the issue, I have absolutely no idea :rofl:

Edit: Actually there’s an easier way than running the terminal command, as apparatus noted (and I missed) you can just add “pci=nomsi” to your kernel ops for the VM.