NovaCustom NV41 [Qubes 4.2]

Everything working great. I ordered the laptop without camera and Wifi/BT chip

  • No Wi-Fi/Bluetooth chip
  • No Camera

Brand: Notebook
Model: NV4xPZ

CPU: 12th Gen Intel(R) Core™ i5-1240P
Chipset: Intel Corporation Device [8086:4621] (rev 02)
Graphics: Intel Corporation Alder Lake-P GT2 [Iris Xe Graphics] [8086:46a6] (rev 0c) (prog-if 00 [VGA controller])

RAM: 65376 Mb

QubesOS version: R4.2.0
BIOS: Dasharo (coreboot+UEFI) v1.6.0
Kernel: 6.6.2-1
Xen: unknown

HCL Report:

brand: |
model: |
bios: |
Dasharo (coreboot+UEFI) v1.6.0
cpu: |
12th Gen Intel(R) Core™ i5-1240P
cpu-short: |
chipset: |
Intel Corporation Device [8086:4621] (rev 02)
chipset-short: |
gpu: |
Intel Corporation Alder Lake-P GT2 [Iris Xe Graphics] [8086:46a6] (rev 0c) (prog-if 00 [VGA controller])

gpu-short: |
network: |
Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
memory: |
scsi: |

usb: |

  • works:
    qubes: |
    xen: |
    kernel: |
    remark: |
    credit: |
    link: |


Thanks for the HCL report! I submitted it to the repository and should appear there soon.




Thank you for HCL. Can you, please, also fill a detailed report, based on this template:

Example of user providing the answers is here. The more information the better, it may be helpful to other users, thank you.


  • Any problems with installation - NO
  • Was latest kernel required? - YES
  • Were some additional kernel options required? - NO

Basic Input

  • Keyboard - WORKS
  • External USB mouse [if possible to check] - WORKS
  • Touch-pad - WORKS
  • Touch-pad supports “tap as click” and scrolling with 2 fingers works, - WORKS
  • Display brightness change shortcuts, - UNTESTED
  • Sound volume shortcuts, - UNTESTED
  • Keyboard led and keyboard brightness change shortcuts, - UNTESTED
  • Output of xinput --list from terminal of dom0 - WORKS
    Virtual core pointer id=2 [master pointer (3)]
    Virtual core XTEST pointer id=4 [slave pointer (2)]
    FTCS1000:00 2808:0101 Mouse id=11 [slave pointer (2)]
    FTCS1000:00 2808:0101 Touchpad id=12 [slave pointer (2)]
    sys-usb: PixArt HP USB Optical Mouse id=17 [slave pointer (2)]
    Virtual core keyboard id=3 [master keyboard (2)]
    Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    Power Button id=6 [slave keyboard (3)]
    System76 ACPI Hotkeys id=7 [slave keyboard (3)]
    Video Bus id=8 [slave keyboard (3)]
    Power Button id=9 [slave keyboard (3)]
    Sleep Button id=10 [slave keyboard (3)]
    Intel HID events id=13 [slave keyboard (3)]
    AT Translated Set 2 keyboard id=14 [slave keyboard (3)]
    sys-usb: LiteON HP Basic USB Keyboard id=16 [slave keyboard (3)}
  • Check if keyboard and/or touchpad is PS/2 connected - Both keyboard and touchpad continued working during the sys-usb pause test.

Internet and bluetooth

  • Ethernet cable connection - works out of the box - WORKS
  • Ethernet cable connection - speed - N/A
  • Wifi connection - N/A
  • Wifi connection - speed - N/A
  • Bluetooth - works out of the box - N/A
  • Bluetooth - shows devices - N/A


  • Suspend/Resume works - WORKS
  • Does resume breaks WiFi - N/A
  • Does resume breaks Bluetooth - N/A

Video [increase VCPU to the qube before test]

  • Fullscreen and windowed video playback of youtube - 720p/1080p/2K/4K in Firefox - WORKS
  • Video file playback of file using mpv/mplayer/smplayer - 1080p - WORKS
  • Multiple displays configuration works (HDMI) - WORKS


  • Speakers (sound playback) - WORKS (was sys-audio used?) - NO
  • Head-phones via 3.5" jack - WORKS
  • Sound output via HDMI - WORKS
  • Audio-optical - N/A


  • Are fans silent - YES
  • Are fans noisier than on Windows/Linux - NO


  • Have you tried running Windows 10 HVM qubes - NO
  • Does CPU boost seem to be working properly - UNTESTED


  • Link to the laptop page on the brand website - NV41 Series 14 inch coreboot laptop - NovaCustom
  • Display native resolution - Full HD (1920×1080)
  • Maximum possible RAM memory - 64GB
  • CPU score - UNTESTED
  • Number of USB Controllers - 3x USB Controller assigned to sys-usb [2 x USB 3.2 Gen. 1 port (Type A), 1 x USB 3.2 Gen. 2 port (Type C), 1 x USB 3.2 Gen. 2 port (Type C)]
  • Internal TPM - TPM 2.0

With Qubes OS 4.2 you shouldn’t need “latest kernel”

That’s right, but I did the initial setup on the NV41 6 months ago with 4.1 and upgraded to 4.2 a few days ago.

Hi, did you encounter any issues with external displays? If you of course had a chance to test that…

The hdmi output works fine for me with a 144 Hz 1080p screen, I can also connect the screen through an usb-c dock connected on the thunderbolt port. I don’t have enough screens to try two externals screens at the same time.

1 Like

I tried a 4k display with another laptop. It was a bad experience. All tweaking solutions I could find failed (min vram etc). Perhaps it was my bad. By the way, great NV41 report in your blog!

I think it’s unfortunately a Qubes OS issue :frowning: I was running Qubes OS on a 4K screen last year, it was a pain to figure all the tweaks to get normal size everywhere (it was working though).

you should write a thread to get some help, it should be easy to fix the vram configuration :+1:

I have been using a 4K monitor 3840x2160 16:9 with Qubes under Lenovo x220 & Coreboot, Lenovo x230 & Coreboot, Lenovo w530 & Coreboot for years without any problems. This is also the case with the current NovaCustom NV41 System via the HDMI interface, without any tweaking soulutions.

1 Like

Which USB-C docking station model are you using? I have tried the Lenovo docking station “ThinkPad Thunderbolt 4 Workstation Dock” on the Thunderbolt port. Unfortunately, I no longer have an Internet connection etc. and the Qubes panel is not displayed on either screen.

I use this thing

Did you connect a 4K monitor to this DS?

no, I don’t have any 4K monitor to try :frowning:

Okay and thanks for your feedback.
I’ll have to test other Lenovo DS models to find out the reason for the missing Qubes taskbar and internet connection.