No wifi on Qubes r4.2

so, i had a really nice setup of qubes running, until i saw some qubes had updates - so i did the updates, and then internet went out - i texted my room mate, and their wifi was down, too. but then their wifi came on, so i rebooted my qube a few times (it used to get stuck until i rebooted sys-net). nothing worked, did lots of research, nothing worked. so i just thought… i know how i got where i did with all my progress with my qubes, I’d learned enough. so I’ll do a clean install.

skip forward about 2 hours in, and the problem still persists, even after rebooting. the weird thing is my DNS is working - it’s getting the ips of the websites I’m trying to ping, but just not pinging - and this is from within sys-net. my wifi chip is on board- I’m running a custom rig. asus x570 mobo with wifi. anyone else running into these issues? what should i try tomorrow? I’ve spent about 6-8 hours on this today, and I’m beat for the day.

Try to boot from some LiveUSB and check if internet will work there.

in part of my reinstall, i installed fedora, and downloaded the latest qubes there - so yes, it works everywhere else other than qubes os

It’s strange that your DNS resolving is working but ping is not.
Are you able to ping your router IP address in sys-net?
Or DNS server IP address?

I’m actually a noob at networking… I’m just trying to get by by the little i do know - by pinging my router, do you mean pinging my external IP? Or is it another address?

i do know i can ping an Ethernet connection that’s connected to my NAS, the LAN connection. and it does go through… also did not work.

You’re connected to WiFi router and its LAN IP address is used as your gateway IP address in sys-net. It’s often used as DNS server as well.
You can right-click on the NetworkManager (wifi) icon in the dom0 tray → Connection Information, there you can see the address of your router and DNS server e.g.:

Default Route
Primary DNS

Try to ping these addresses.

1 Like

alright. I’ll give it a try tomorrow, as, I feel defeated and am going thru some cptsd tonight, so i can’t really do much atm. thank you!

wait, i just realized. my LAN IP is a loopback, and so is my router ip, judging by the look of what you sent… so why test for it? I’m not doubting you as much as trying to learn

The Connection Information windows should have multiple tabs with the names of your connections like “MyWiFiAP” and “lo”, where MyWiFiAP is your WiFI connection and lo is your loopback interface.
You need to check the MyWiFiAP tab.

1 Like

How did you configure your networking in sys-net? Was it using NetworkManager applet in dom0 tray or some other way?

it was completely vanilla. i just clicked the icon in the top right, then entered wifi pass code, same way i do with my wired connection-- except that one has no pass ofc. i don’t know all the different ways you can, but think the easiest, and that’s probably what i did

Then you should have separate tab for your WiFi connection in Connection Information window.

1 Like

i likely do - I’ll be able to confirm tomorrow. I’m sorry, I’m just really out of it rn. I’ll talk to you then - also, if you have any ideas between now and then, i don’t mind if you post here for me to try a list of ideas - but that’s only if you do. thank you. catch you tomorrow

Check the output of this command in sys-net terminal as well:

ip r

you know what, I’m actually gonna get up and work on it just a little bit more now that I’m getting support and am not alone. I’m only gonna go for up to an hour or two - if we can’t tonight, hopefully we can fix tomorrow. I’ll get you those commands in a moment

i am able to ping my router. and here’s the result of my ip r

Are you connected to some network using Ethernet cable as well?
Does it have internet?
It seems that it’s trying to use your Ethernet connection for internet instead of your Wireless connection.

that ethernet is the one going to my NAS - it does have network, yes (at least it can be pinged). how can we switch the primary connection to wifi while keeping the ethernet working?

Edit the connections and change the priority in the General tab “Connect automatically with priority”.
Higher numbers means higher priority, if I remember correct.

1 Like

tried that just now, and it’s still not working unfortunately. that said, i just clicked “open terminal in qube” and found something interesting. but it’s not letting me attach the image bc I’m editing. so one sec