No wifi on Qubes r4.2


the ?s are suspicious in that it may be part of the problem

I’ve never tried “Connect automatically with priority” so maybe that’s not how it works.
Then edit the ethernet connection → IPv4 Settings tab → Routes… button → enable “Use this connection only for resources on its network”
You can also edit IPv6 Settings if your network has IPv6.

1 Like

These are unrelated messages.

1 Like

dang. i enabled that, still nada.

Did you restart networking?
Disable and enable it by right-clicking on the Network Manager applet in the dom0 tray.

i tried that just now, as well as rebooting sys-net, and still nothing from the pings to Google.

the weird thing is, it’s saying it’s connected when i do all this - through a notification

Check the output of this command in sys-net terminal:

ip r

we already did that earlier - but I’ll try again to see if wifi is primary now.

don’t mind the stuff above it - those were just some tests

It seems that you’ve enable “Use this connection only for resources on its network” for your WiFi connection instead of Ethernet connection.

oh crap, that means i misread your initial comment. my bad. lemme try that now

YES. IT’S WORKING. THANK YOU! after i enabled the option in the right place, it worked perfectly