No WiFi in Networkmanager


first of all I am fairly new to Qubes Os. Before I used Ubuntu, then switched over to Manjaro KDE Plasma and finaly to qubes.

Now I have the problem that my WiFi is not showing in my Networkmanager systray. Ethernet is possible and works.

Devices attached to sys-net:

Services enabled on sys-net:

As you can see my WiFi adapter is connected to sys-net and therefore it should be possible to use it. I have no clue why it does not.
My sys-net is using fedora-34 template and I am using the 4.1 version of qubes os. Also there are no updates avaiable for all templates.

I also downloaded the official linux driver from intel (iwlwifi-ty-59.601f3a66.0.tgz) and copied it to firmware folder on TemplateVM, which did not help either.

Thanks for any help!

switch sys-net template to debian-11, no need to configure anything, it should work.
or if you insist wanted fedora as sys-net, try download iwlax2xx-firmware-20220509-132.fc34.noarch.rpm Fedora 34 Download and install to the template. I think it should work.

1 Like

Switching to debian does not help either.
When trying to install this on fedora I get the message that this is already installed.

1 Like

Looks like this also did not help.
Furthermore I noticed I am unable to update dom0.
When using the Qubes Update I get the following details: dom0 Update -

And when trying to update via Qubes Manager I get the following:

Maybe this could be the problem?
Since I am also only able to select Kernel 5.10x

I have the same problem with dom0 updates.
Seems to be a transient problem with repo.

1 Like

For me it happens from time to time over tor, especially 404s

You can try this from here:

Getting the AX210 no vPro wifi working: this one has been a pain in the ass. so far, the only way I can get it working is this: Using kernel 5.10.109-1 Install firmware-iwlwifi in template On VM boot:

Get a root terminal
  • rm /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm
  • modprobe -r iwlmvm && modprobe -r iwlwifi
  • modprobe iwlwifi && modprobe iwlmvm

This gets the wifi working until I shutdown Further work to be done here for sure

1 Like

Also you can try to install kernel-latest-qubes-vm and use kernel-latest for your VM.
It helped someone:

1 Like

So I tried a few things now.

Installed newest non-LTS Kernel via kernel-latest-qubes-vm.
This results in getting the Kernel 5.16.18-2.fc32
I applied this to all qubes and restarted sys-net
-did not work

Tested the code posted by @tzwcfq
-did not work

Installed fedora-35, updated it and used it for sys-net
-did not work

Also I tried to use fedora-35 and debian-11 for sys-net
-both did not work

I do not understand why wifi is not working here, given the fact that it did work in Ubuntu while I used it and even with debian here in qubes it does not work
I start to get crazy about this :smiley:

If it is needed my notebook is the following: MSI GP66 Leopard 11UG-248

TOR is shutdown anytime I use clearnet and sys-net is configured as UpdateVM. This was not the problem I guess. But it works now, seems that this was only temporary issue.

What do you have in this command output?
sudo dmesg | grep iwl
Check this command output and get the iwlwifi-so-a0-hr-b0-XX.ucode from the output with the latest XX number supported by your kernel from here:
Or from tar signed archive from here:
Then copy this file in /lib/firmware.

1 Like

The output of the command: sys-net dmesg -

Sorry but I think I do not understand what I have to put in the part of “XX”, so I have downloaded the newest tar and moved the whole content over to firmware folder and overwrite all existing files. Hope this was correct, I’m still learning :smiley:
But this did not help either, still no Wifi access in Network-Manager.
Here is the output of the command after mv of this tar: sys-net dmesg2 -

Ok forget about my previous post, it was for AX201 and its drivers are missing in debian firmware-iwlwifi package so I thought that your driver is missing as well.
I’ve checked your log and this error:

[ 4.191180] iwlwifi 0000:00:06.0: Timeout waiting for PNVM load!
[ 4.191303] iwlwifi 0000:00:06.0: Failed to start RT ucode: -110

Should have been fixed in kernel 5.16:

1 Like

Do you have the same error if you run these commands?

sudo rm /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm
sudo modprobe -r iwlmvm && sudo modprobe -r iwlwifi
sudo modprobe iwlwifi && sudo modprobe iwlmvm
1 Like

Weird, since I am using 5.16.x kernel atm and also I tried fedora-35 before switching back to debian-11 without success as David mentioned this should work.

While running these commands I get no errors, but when I run grep iwl after that, yes same errors.

Maybe there is a problem with kernel from Qubes package.
You can try kernel from fedora/debian template instead maybe it’ll work:

1 Like

Also maybe it was broken again after kernel 5.16.5. You can try to use kernel-5.16.5 from Qubes first:
sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing kernel-latest-qubes-vm-5.16.5-1.fc32.qubes.x86_64

1 Like

Running your command results in: “No match for argument: kernel-latest-qubes-vm-5.16.5-1.fc32.qubes.x86_64”

And for using a VM Kernel, I do not know if I am doing it right:

  1. Run “sudo qubes-dom0-update qubes-kernel-vm-support kernel-devel” in dom0
  2. Run “sudo qubes-prepare-vm-kernel 5.10.112-1.fc32.qubes.x86_64 4.1.qubes” in dom0
  3. Run “sudo apt install linux-image-amd64 linux-headers-amd64 grub2 qubes-kernel-vm-support” in debian-11 template
  4. Set Kernel of sys-net to “none” since virtualization is HVM?

Output of Debian:

If this was correct, this unfortuantely also did not work ^^

Then you can try to manually download the package and move it in dom0:

Then install it in dom0:
sudo dnf install /path/to/kernel-latest-qubes-vm-5.16.5-1.fc32.qubes.x86_64.rpm

I’ve linked to the specific topic in document:

Using kernel installed in the VM

Both debian-9 and fedora-26 templates already have grub and related tools preinstalled so if you want to use one of the distribution kernels, all you need to do is clone either template to a new one, then:

qvm-prefs <clonetemplatename> virt_mode hvm
qvm-prefs <clonetemplatename> kernel ''

If you’d like to use a different kernel than default, continue reading.

Clone your sys-net template (fedora-35 for example) and change cloned template qvm-prefs then select this cloned template as sys-net template and set sys-net kernel to (none).

1 Like

Both do not work unfortuanetly.
Additionally I tried to use 5.15.11-1 Kernel, since I used a 5.15.x one on KDE Plasma, but this also did not work