No network after install

I’m new to qubes-os and I just installed it. At first boot, every icon in the “Q” menu at the top left corner is a padlock.

When I try to configure a network connection in xfce control panel, all I can do is select “Ethernet” and there’s nothing I can do after (everything is greyed out).

I tried to reinstall it and it’s just the same. Qubes-R4.0.3-x86_64.iso and the hash was OK. ₕₑₗₚ!

I’m new to qubes-os and I just installed it. At first boot, every
icon in the “Q” menu at the top left corner is a padlock.

Don’t worry about this. That’s kind of normal. The padlock doesn’t mean
that it’s locked or doesn’t work. In an upcoming version the padlocks
will be replaced by little cubes :wink:

The actual app icons may or may not show up after a while. Don’t let
that stop you.

When I try to configure a network connection in xfce control panel,
all I can do is select “Ethernet” and there’s nothing I can do after
(everything is greyed out).

That most likely means that your WiFi adapter wasn’t recognized by the
template used by sys-net. I assume since you just installed that’s
Fedora? In that case it might help to search online for help how to make
your adapter work with Fedora and then do that to the template.

You only need the adapter to work in the template sys-net is based on.

Let me try and walk you through it. First, please open the dom0 Terminal
and run these commands:

qvm-pci > qvm-pci.log
lspci > lspci.log

then you can use the qvm-move-to-vm command to move those to log files
to whatever qube you use to interact with this forum and post them
(that’s if you have an Ethernet connection to the internet). Otherwise
load them on a USB drive and send them from another PC.

What those log files will tell us: what WiFi adapter you have and if it
is assigned to sys-net

1 Like

I have the same problem but sysnet actually recognizes my Network Controller

Thanks for your help Sven! Here’s the content of lspci:

00:00.0 Host bridge: Intel Corporation Device 3e30 (rev 0d)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 0d)
00:12.0 Signal processing controller: Intel Corporation Device a379 (rev 10)
00:14.0 USB controller: Intel Corporation Device a36d (rev 10)
00:14.2 RAM memory: Intel Corporation Device a36f (rev 10)
00:16.0 Communication controller: Intel Corporation Device a360 (rev 10)
00:17.0 SATA controller: Intel Corporation Device a352 (rev 10)
00:1b.0 PCI bridge: Intel Corporation Device a340 (rev f0)
00:1c.0 PCI bridge: Intel Corporation Device a338 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Device a330 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device a305 (rev 10)
00:1f.3 Audio device: Intel Corporation Device a348 (rev 10)
00:1f.4 SMBus: Intel Corporation Device a323 (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device a324 (rev 10)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-V (rev 10)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/580] (rev e7)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 580]
02:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd Device a808

And here’s qvm-pci:
dom0:00_00.0 Host bridge: Intel Corporation
dom0:00_01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16)
dom0:00_12.0 Signal processing controller: Intel Corporation
dom0:00_14.0 USB controller: Intel Corporation
dom0:00_14.2 RAM memory: Intel Corporation
dom0:00_16.0 Communication controller: Intel Corporation
dom0:00_17.0 SATA controller: Intel Corporation
dom0:00_1b.0 PCI bridge: Intel Corporation
dom0:00_1c.0 PCI bridge: Intel Corporation
dom0:00_1d.0 PCI bridge: Intel Corporation
dom0:00_1f.0 ISA bridge: Intel Corporation
dom0:00_1f.3 Audio device: Intel Corporation
dom0:00_1f.4 SMBus: Intel Corporation
dom0:00_1f.5 Unknown: Intel Corporation
dom0:00_1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-V sys-net
dom0:01_00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/580]
dom0:01_00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 580]
dom0:02_00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd

I also joined a screenshot of what happens when I try to open pretty much any VM template (I can open the settings and that’s it). The PCI device in question is my ethernet which is directly on my motherboard Screenshot_2020-12-15_16-32-09|690x388

Hi @franc01s,
I’m also using an I-219 V Intel ethernet card with Qubes-OS, my network works:

user@sys-net:~$ lspci | grep Ethernet
00:06.0 Ethernet controller: Intel Corporation Device 0d4f
user@sys-net:~$ lspci -v -s "00:06.0"
00:06.0 Ethernet controller: Intel Corporation Device 0d4f
	Subsystem: Intel Corporation Device 2081
	Physical Slot: 6
	Flags: bus master, fast devsel, latency 64, IRQ 71
	Memory at f2000000 (32-bit, non-prefetchable) [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: e1000e
	Kernel modules: e1000e

user@sys-net:~$ ip a show dev ens6
2: ens6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 1c:69:7a:aa:bb:cc brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.99/24 brd 192.168.1.255 scope global dynamic noprefixroute ens6
       valid_lft 2683sec preferred_lft 2683sec
    inet6 fe80::aaaa:bbbb:cccc:dddd/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
user@sys-net:~$ uname -a
Linux sys-net 5.6.16-1.qubes.x86_64 #1 SMP Sun Jun 7 06:13:04 UTC 2020 x86_64 GNU/Linux

I think you should update your kernel as I explained it in the mailing-list last summer. But it could be complex for you, I don’t know your Linux skills…

A simpler solution is to test the 4.1 alpha ISO.

1 Like

That’s a common issue. Please do this in dom0 terminal and try again:

qvm-shutdown --wait --all

qvm-pci detach sys-net dom0:00_1f.6

qvm-pci attach sys-net --persistent --option no-strict-reset=true
dom0:00_1f.6

The first command shuts down all of your qubes, this is not strictly
necessary but will help avoid complications. The second command remove
the Ethernet adapter from sys-net, while the third adds it again but
with an option telling Qubes that this adapter doesn’t support resets.

Let’s do this and see if we can get at least your Ethernet working.

Regarding WiFi … I can’t even see your WiFi device in the list. A lot
of your devices seem to not be recognized properly. Can you run
qubes-hcl-report in dom0 please and post the resulting .yml file?

1 Like

A simpler solution is to test the 4.1 alpha
ISO
.

That sound like a good idea too. 4.1 comes with a newer Fedora version
in dom0 and it’s more likely everything will just work out of the box.
On the other hand: it’s an Alpha.

Alright mister genius… I tried your commands and nothing happened
but I restarted and here I am writing to you on qubes. Finally!

Makes sense, sorry I forgot to mention the reboot. Glad you figured it out!

Would you happen to know what is this second NIC on my menu?

I’m pretty sure ‘vif’ stands for virtual interface. There must be one in
sys-net: the PCI device is your connection to the outside, the virtual
interface is how e.g. sys-firewall connects to sys-net.

I don’t know why it’s showing up in your network manager, maybe someone
else here does.

As for my wifi card I don’t have any.

Hehe. Then the HCL wasn’t necessary. However if it turns out everything
else is working fine for you now, I can add it to the website if you’re
OK with it:

If it’s gonna help others then do it.

Do you see anything else that seems not recognized?

Again, THANKS a bunch!

Do you see anything else that seems not recognized?

Yeah, ignore that. I was wrong. I am somewhat of a beginner myself, you
where just lucky to run into a problem I saw before. :wink:

1 Like

These commands do not enable the greyed-out-ness for me. Any new ideas?