"No Bootable Device" after Qubes OS installation

Hello dear community :slight_smile:

I was trying to install Qubes OS on my old laptop (Acer EX2511G-58VK). I created my installation stick with rufus and had no problems with configuring the installation.
I created a swap, /boot, /boot/efi and / partition with at least 10 GiB per partition. Except for this I didn’t do any other modifications in the installation process.

But after the installation when I had to reboot my laptop, I got the error message “No Bootable Device”.
I searched this error and there were also some other persons, which had the same issue like me, but I couldn’t solve my problem with the solutions that were provided there.

I’ve tried to create and change the efi boot order.
(efibootmgr -v -c -u -L pastor -l /EFI/qubes/xen.efi -d /dev/sda -p 1)

Does anybody know how to solve the problem?

Thanks in advance and sorry for my english :wink:

Hi @wasabi, welcome to the Community! Did you try to search this forum? For example, this topic looks relevant:

There are also more topics.

1 Like

Hi @fsflover , thank you for your reminder. When I read through the answers agian, I had the idea to just change my BIOS from UEFI to Legacy and I once again installed Qubes and then it worked perfectly fine :slight_smile:


Then mark his post as a solution so it could help other users having similar or exact issue.

1 Like