New user having installation problems Ryzen7 3700X stuck

Hi everybody, trying to install QOS 4.2.1 I noticed the problems errors I get are similar to others with AMD Ryzen 7 and NVIDIA GTX1650…
My system based on MB GigaByte Vision D B550 with 64GB Ryzen7 3700X.
BIOS doesn’t show any specific choice about virtualization or IOMMU…
Already tried latest kernel with same problem.

What is missing in my system to reach Anaconda Installer? It stops before I could see Anaconda

There should be an option to enable SVM and IOMMU:

Can you describe the errors that you see or make a photo?

yes thanks, in few minutes

I selected last kernel.
IOMMU enabled.

Did you verify the installer ISO after downloading?
How did you create installation media?
E.g. did you use Rufus in Windows?

Yes checked before and after installation on a microSD (USB) by Rufus in Windows with DD option

Disable RAID in BIOS if you have it enabled. Change SATA mode from RAID to AHCI and/or disable NVMe RAID.
From your BIOS manual:

SATA Configuration
& SATA Mode
Enables or disables RAID for the SATA controllers integrated in the Chipset or configures the SATA controllers
to AHCI mode.
eRAID Enables RAID for the SATA controller.
eAHCI Configures the SATA controllers to AHCI mode. Advanced Host Controller Interface
(AHCI) is an interface specification that allows the storage driver to enable advanced
Serial ATA features such as Native Command Queuing and hot plug.
& NVMe RAID mode
Allows you to determine whether to use your M.2 NVMe PCIe SSDs to configure RAID.

Already no RAID, yes AHCI.
NVMe i have are empty so i can disable to try installation on a HDD

No need to, the NVMe itself shouldn’t be the problem. But if there is an option that creates RAID out of NVMe devices that could be a problem and this option should be disabled. But maybe there is no such option in your BIOS.

Can you copy the rdsosreport.txt that is generated after the installer fails to boot and check it to find the exact errors that cause the boot to fail or upload it here?
Press Enter on this screen and you can copy the file to some of your disks.

Where should be saved that txt file ?

I disabled NVME at all.
CSM support enabled, right?

You can enable it.

You can save the file to your HDD/NVMe/USB disk.

It shouldn’t matter.

Now boot with last changes screen remains totally dark and don’t show any text

What did you change from the time when installation failed with a log messages?
Screen remains dark after selecting any installer GRUB menu entry?

I reenable NVMe … Now i made a new burn from Rufus, checked che SHA256 and match, booting with choice “last kernel”, then appear for half a second few lines on screen and then fully dark and game is over.
I tried from BIOS both option " UEFI and not UEFI boot from USB"

Before i was booting from an ISO in a Ventoy USB disk and was somehow better

Remove the quiet kernel command line option in the installer GRUB menu entry e.g. like this:

Maybe you’ll be able to see the logs.

Ventoy is not supported: