New Installation No Templates only dom0 (AMD Framework 13)

I’m new to Qubes and am very interested in this approach to security. I’m trying Qubes on my new Ryzen 7 Framework, I mention this as there might be some hardware incompatibility issues I may run into.

For example I’m adding x2apic=false to the bootup, which has bypassed issues I’ve had with system hangs at installation.

I am trying the 4.2 RC4 beta release. I had more issues with the 4.1 stable release even with the above fix.

Right now my issue is that I can complete an install of 4.2 but there are no template VMs and I only have dom0.

These are the only errors visible during installation:
Drcut-initqueue[1506]: Unknown device “/dev//run/install/repo//images/install.img”: No such device
Dracut-initqueue[1507]: Unknown device “/sys/”: No such decice

The installer will complete but rebooting results in just dom0, no Fedora or Debian templates, so sys-network or other qubes. Which makes sense as the software section on the looks like:

And YES, I have tested the checksum of the .iso downloaded multiple times, different ways (direct from the website and torrents), and used several different USB drives-- all of which have been used successfully for other lives and installs.

I used the command:

$ sudo dd if=Qubes-R4.2.0-rc4-x86_64.iso of=/dev/sdb status=progress bs=1048576 conv=fsync

I’m stumped, any insights would be helpful.

It’s normal, the templates are installed on first Qubes OS boot when Initial Setup is started.
Seems like you’ve encountered some bug and the initial setup didn’t start for you on first Qubes OS boot. Try to run it manually in dom0:

1 Like

Thank you!

I was able to get it started but now it hangs at
“Installing TemplateVM debian-12-xfce”

I found this pervious post describing this same behavior but no resolution.
Hangs on initial system setup

You can check the logs in dom0 terminal with sudo journalctl, maybe there will be some relevant info.

1 Like

Okay so I ran that and right after the line from Anaconda

INFO: program:Running… /usr/bin/qvm-template install --nogpgcheck /var/lib/qubes/template-packages/qubes-template-debian-12-xfce-4.2.0

The error is

PAM unable to dlopen(/usr/lib64/security/ /usr/lib64/security/ cannot open shared object file: No such file or dorectory
PAM adding faulty module: /usr/lib64/security_

Im going to look into this more tkmrrw but thought id post if there are any immediate things that might come to mind.

This error should be unrelated and the issue is somewhere else:

So I had been trying to get Debian as my default in the installer. I tried keeping it Fedora and i was ale to successfully install and update all qubes.

Unsure what this meas but I’ll close out this post now that my initial problem has been solved.

I have a couple minor issues like no gui for decryption at boot and my trackpad won’t work but is detected, but I’m one step closer now!

Thank you :slight_smile: