New install wifi adapter driver problem

I just installed Qubes 4.1.1. I connect to wifi with an USB adapter so I picked the sys-net option for usb devices during the install. The adapter that I have connects automatically with Fedora but I had to install the driver via cd-rom in Debian. Since Fedora is my default template I expected it to automatically come up but it didn’t. So I popped in the cd and it comes up as connected to dom-0. I attach to sys-net but after that I can’t find it. I tried mounting the drive but couldn’t locate the right one. I can’t connect to the web without getting this figured out so if anyone has any ideas I would appreciate it.

Sorry, but I’m totally confused with what you are trying to achieve (what is your goal) as well as what exactly did you do in each step you mentioned in order to achieve that goal. Probably someone else understands the situation better.

I am trying to connect to my Wi-Fi network in my house. I am using a panda usb Wi-Fi adapter. Qubes is not automatically recognizing the adapter and allowing me to connect to the network with a password, like Fedora does. I am trying to get sys-net to recognize the usb device but nothing I’ve found and tried on the website or in this forum works. I’ve tried to mount to the default Fedora template as well. I’ve tried to install the driver on cdrom supplied with the panda device but I can’t even do that. It shows the driver on my devices icon and I attach to sys-net or the fedora temp but after that I can’t locate it or mount it.

Hi @Cad,

Panda wifi dongles should have mainline Linux support for their basic functions. I’m not sure about they’re “advanced features” that Panda says they have…

That is surprising, because NetworkManager should pick it up straight away.

Well then, let’s see if we can get it working, and this thread will become instructions for everyone else! :slight_smile:

If you mean that you passed a USB bus to your template, I really wouldn’t do that… :woozy_face:

That’s the easiest way to get pwned if your USB device is nasty…

When you plug it in and attach the USB device to sys-net, what does dmesg say in sys-net? Are there any errors?

This will help us figure out what’s going on…

If you don’t understand anything from what we’ve said, just ask for clarification :slight_smile:


I have found this:
https://www.pandawireless.com/download/LinuxDriver4Fedora_v2.5.0.3.tar.bz2

…but be careful. It appears to build a kernel module and require sudo to build (not install, BUILD)…

I attached the dvdrom to sys-net and ran sudo dmesg. It returned many lines, most of which I do not understand. There are a few tasks that were skipped because of a failed condition check. These include ostree-remount, and a couple systemd.service. In red it says cannot open /etc/target. In red it says SMBus host controller not enabled! I believe this may contain the address of the usb controller for the Wi-Fi adapter. There are a bunch more lines after this stuff but they look ok to me(no red or failure type words).

That DVD likely contains source code for kernel versions 4 or 3 (Qubes OS uses version 5), and I’d be very surprised if it was of any use to you, unfortunately…

That’s why you paste them here so we can help you.

sudo dmesg | grep -i error

That’s normal inside a VM.

It comes back-

[ 0.923492] RAS: Correctable Errors collector initialized.

I cant copy/paste because I have to use a machine that connects to the internet to access this forum.

Thank you for your help.

This has nothing to do with your USB wifi device. That’s telling you that the Linux kernel RAS subsystem (a very cool thing that checks your hardware for defects and loose connetions, and helps mitigate them) has successfully initialised.

This is a good thing!


Can you please post the output of lsusb?

Basically, we need to know what the Panda USB wireless device is telling your machine it is.

Once we know what it’s registering itself as (I am 95% certain there will be a mainline kernel driver for it, because the hardware is more than ten years old from what I can see), we should be able to get it working.

I have not been able to find any information about it online.

EDIT: I haven’t been able to find any useful and transparent information about it online… :woozy_face:

lsusb in sys-net returns-

Bus 001 Device 002: ID 0627:0001 Adomax Technology Co., Ltd QEMU Tablet
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsusb in dom0 shows the adapter, along with everything else I have plugged into a USB port. The specific device lists -

Bus 002 Device 002: ID 148f:5572 Ralink Technology, Corp. RT5572 Wireless Adapter

I was trying to say in the original post that I have used this adapter on this machine when I had Debian and also with Fedora. Both installed on bare metal. Fedora recognized it immediately but Debian required that I install the driver via the disk supplied with the adapter.

Also the tablet it is showing is a Wacom pen device that functions just fine.

Wait… is the Panda Wifi USB device in dom0, or in sys-net?

If it’s in dom0, then of course it won’t work as a network interface.


From what it sounds like, you haven’t got yourself a sys-usb set up, and have just passed a USB bus into sys-net (most likely from the sys-net qube settings, I’m assuming?).

So, your sys-net has basically been given a USB port (along with anything else that was connected to that USB bus that you passed through).

While this will “work”, it won’t allow you pass those USB devices around between different VMs.

(Oh, and if someone plugs a rubber ducky or BadUSB into the USB port that dom0 can see, well, you’re pretty much screwed then :wink: )


To illustrate this, try this:

Unplug your Wacom tablet (very nice, by the way :laughing:), and plug the Panda Wifi device into the exact same port that the Wacom tablet was plugged into.

It works, right? :wink:


If you haven’t, I would really recommend you to set up a sys-usb qube. This will allow you plug in thing like USB keyboards/mice, printers/scanners, audio headsets, and anything else with a USB plug; and then pass them through to your other open Qubes VMs.

This guide will help you:

Oh, and feel free to ask any more questions you might have :slight_smile:

Good question. The adapter itself is stuck in dom0 as far as I can tell. The driver for the device is in the dvdrom drive which I have attached to sys-net via the data block icon in the top right corner. If you could tell me how to mount that drive in sys-net so I can install the driver, it may help. Unless you have another idea.

Forget the DVD. The driver has been in every single Linux kernel for the last 8 years (the kernel module is called rt2800usb). Trust me, you don’t need it :stuck_out_tongue:

(on a side-note, any manufacturer who thinks it’s ok to use a 4.4GB DVD to provide 1-20MB worth of files should be fined, because it’s such a waste of a DVD…)

The issue isn’t drivers. The issue is that sys-net can’t see your Panda USB device. That is why it’s not being recognised. :slight_smile:

Did you try what I suggested above about unplugging the Wacom tablet and plugging the Panda USB in the same port?

(This is not the solution. This is merely to show you how you set your system up…and also to verify that nothing else is “broken” on your system :stuck_out_tongue: )

The ports all work as well as the devices. I’m dual booting with Fedora for now until I get Qubes figured out. Everything works gloriously in Fedora.

Ok. You are not understanding what I am saying.

What I want you to do is this:

  1. Unplug your Wacom tablet
  2. Plug the Panda Wifi device into the exact same port that the Wacom tablet was plugged into
  3. Tell me what happens

Does your computer have wifi?

I know what your getting at. I dont have a hardware issue. Everything works fine on this machine when I use Fedora and not Qubes. It’s not hardware. It’s something Qubes is doing

So, does the Panda USB device work when you plug it into that particular USB port or not…?

No. And I don’t think I want to waste any more time here.

Well, you obviously don’t, given your last post.

When did I say that you had a hardware issue…? I don’t recall ever saying that you did…

Look, it sounds like your USB passthrough isn’t set up properly. That’s all. It’s all clearly written in the Qubes OS documentation, including how to fix it yourself.


Well please forgive me for trying to help you… I tried my best given the incredibly confusing and ambiguous (and mostly inaccurate) information you gave me, and I’m sorry if it wasn’t good enough for you…

Once you’ve passed it through to sys-net:

sudo mkdir -p /mnt/removable
sudo mount /dev/xvdi1 /mnt/removable

It won’t do anything, but hey, knock yourself out!

1 Like