Network card on Mac mini 7,1

I’m trying 4.0.4 on Mac mini late 2014. Installation goes fine and all seems to work but no network cards, both Wi-Fi and Ethernet. Tried all solution I founded, but ifconfig does not show interfaceces

lspci -vnn | grep -i broa
00:06.0 Ethernet controller [0200]: Broadcom Limited NetXtreme BCM57766 Gigabit Ethernet PCIe [14e4:1686] (rev 01)
Subsystem: Broadcom Limited NetXtreme BCM57766 Gigabit Ethernet PCIe [14e4:1686]
00:07.0 SD Host controller [0805]: Broadcom Limited BCM57765/57785 SDXC/MMC Card Reader [14e4:16bc] (rev 01) (prog-if 01)
Subsystem: Broadcom Limited BCM57765/57785 SDXC/MMC Card Reader [14e4:0000]
00:08.0 Network controller [0280]: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)

Tried install broadcom-sta-dkms on Debian 10 and switched the default template of sys-net → no success

Tried recompile fedora33 with broadcom-wl, akmod-wl → no success

Tried modprope tg3 → no success

lsmod | egrep ‘tg3|wl’
wl 6463488 0
cfg80211 774144 3 wl,mac80211,rtl8187
tg3 188416 0
libphy 77824 1 tg3

I was able to connect to the internet with a usb wifi dongle. If anyone has had success and wants to help me, it is appreciated. Thanks

For the wifi, this stack exchange post suggests removing conflicting drivers:

modprobe -r b44 b43 b43legacy ssb brcmsmac

Thanks airelemental, I tried this guide, but i’m using a wrong kernel I think:

apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package linux-image-5.4.98-1.fc25.qubes.x86_64 E: Couldn't find any package by glob 'linux-image-5.4.98-1.fc25.qubes.x86_64' E: Couldn't find any package by regex 'linux-image-5.4.98-1.fc25.qubes.x86_64' E: Unable to locate package linux-headers-5.4.98-1.fc25.qubes.x86_64 E: Couldn't find any package by glob 'linux-headers-5.4.98-1.fc25.qubes.x86_64' E: Couldn't find any package by regex 'linux-headers-5.4.98-1.fc25.qubes.x86_64'

I selected HVM in debian template, and installed the broadcom-wl-dkms with success.

modprobe -r b44 b43 b43legacy ssb brcmsmac
modprobe wl and then shutdown debian template. Changed sys-net default template to debian 10 (also removed the kernel fc25 from the setting). It does not work, but i found this in dmseg:

[ 50.761159] wl: module license 'MIXED/Proprietary' taints kernel.
[ 50.761161] Disabling lock debugging due to kernel taint
[ 50.762843] Adding 1048572k swap on /dev/xvdc1. Priority:-2 extents:1 across:1048572k SSFS
[ 50.762936] [TTM] Zone kernel: Available graphics memory: 1005210 kiB
[ 50.762937] [TTM] Initializing pool allocator
[ 50.762940] [TTM] Initializing DMA pool allocator
[ 50.769418] xen: --> pirq=18 -> irq=17 (gsi=17)
[ 50.794276] wl driver (r587334) failed with code 1
[ 50.794278] ERROR @wl_cfg80211_detach :
[ 50.794278] NULL ndev->ieee80211ptr, unable to deref wl

UPDATE: after

qvm-pci a sys-net dom0:02_00.0 --persistent -o permissive=true

Wi-Fi works! :slight_smile:

UPDATE2: Driver tg3 from broadcom site, source compiled, version 3.138a error in dmesg:

[ 37.294041] tg3 0000:00:07.0: tg3_test_dma: Buffer write failed. err = -19
[ 37.295261] tg3 0000:00:07.0: DMA engine test failed, aborting

I’ve also this, but i don’t know if it’s related
[ 1.215208] piix4_smbus 0000:00:01.3: SMBus Host Controller not enabled!

and from xl dmesg | grep-i dma

(XEN) Intel VT-d Dom0 DMA Passthrough not enabled.
(XEN) [VT-D]DMAR:[DMA Write] Request device [0000:00:14.0] fault addr 1f50fc000, iommu reg = ffff82c0009f4000
(XEN) [VT-D]DMAR: reason 05 - PTE Write access is not set
(XEN) [VT-D]DMAR:[DMA Read] Request device [0000:00:14.0] fault addr 1f3ab8000, iommu reg = ffff82c0009f4000
(XEN) [VT-D]DMAR: reason 06 - PTE Read access is not set

but idem i don’t know if errors are related

1 Like

UPDATE3: Ethernet is working now! I had to put in PV the vm. It seems there is a problem with the nextreme passthrough. Now all works as expected.
I hope this will help someone with same problems without spending hours of troubleshooting :slight_smile: