Monitor Details Not Detected Properly


I already created a post to the topic, but since the problem here was still very general and it became confusing and included many other causes of errors, I’m creating a second ticket that really only deals with the topic directly, so that future readers with similar problems don’t have to read too much :wink:

Long story short: My monitor details (name, resolution, hz) is not being recognized. Not on my “old” monitor from acer, not on my brand new monitor from samsung. Hz is e.g. only 86 instead of 240, name is always “default” and not the real monitor name and resolution is not right.

Also: There aren’t any standard profiles; and I cant create new profiles. When I want to create new profiles using xandr and apply them then they are not really applied; the display does not change so the setting doesn’t change anything. In addition, the new profile i create are all deleted once i restart my pc.

I already installed the propertiary nvidia driver with this tutorial:

I use these kernel parameters:

  • "... quit splash nomodeset rd.driver.blacklist.nouveau video=vesa:off nvidia-drm.modeset=1"

If i don’t use nomodeset then my new monitor says that the resolution is not supported as soon as luks is decrypted, my old one shows a verry buggy picture that does not change (also as soon as luks is decrypted).

video=vesa:off and nvidia-drm.modeset=1 didn’t have any effect yet; but after a little bit of reserach it seems as if they were actually there to solve such a problems so I’ll leave it there so that it’s documented.

I already played around with kernel parameters the whole day and once it worked: monitor name got recognized, correht hz, …
But of course I forgot which parameter I changed and i didn’t think of journalctl | grep “Command line”. I obviously tried all of them again later as soon as @apparatus told my about the command, but I couldn’t recreate it.

I would like to point out that I’m not so sure whether it was purely the kernel parameters or “coincidence”, so I wouldn’t get hung up on that; but it should definitely be proof that it is basically possible.

PS: I’ve got a Nvidia 3070 & lspci shows that the nvidia driver is in use.

It should be rd.driver.blacklist=nouveau, but I guess it’s just a typo in the forum post and you have correct option in your GRUB config.

You can upload your boot log from the boot where your monitor is not working, maybe someone can notice something related to this in the log.
E.g. you can get the previous (-1) boot log using this command:

journalctl -b-1 > journalctl.log

Sorry for the late reply.

I was able to solve the problem by running “nvidia-smi” even if it is not recommended.

Since then, 3 kernel modules are shown when running lspci: nouveau, nvidia_drm (this is the new one), nvidia

Thanks for help!