False monitor resolution

This is currently the only monitor & it is connected to the graphics card. nothing is connected to the motherboard.

This is where currently nothing is happening anymore.

Are you testing this with your new monitor? Does your old monitor have the same issue?
Maybe Qubes OS is trying to output the image using your iGPU instead of dGPU for some reason. Or maybe different dGPU port?
Is there an option in your BIOS to select the Primary Graphics card or something similar, where you can select either integrated or dedicated card?
You can also try to blacklist your iGPU driver with this kernel option in GRUB if you have Intel CPU:
rd.driver.blacklist=i915

So: updates.
Kernel params nomodeset + nouveau.modeset=0 + rd.driver.blacklist=nouveau gives me an picture and lspci shows that nivdia driver is in use! But… it still isn’t the right resolution, the monitor name is not recognized, etc.

I think the problem is that somehow nouveau still starts. I don’t know how, the kernel paramereters seem to not do their job because lsmod grep nnouveau still outputs 10 items…

To your questions: I am mainly trying with my old monitor. But e.g. right now i am trying it with both. Both monitors have the same issues & are from different manufacturers (samsung & acer).

The idea with bios was good & i did it, but it didn’t change anything, as well as rd.driver.blacklist=i915 didn’t change anything.

I think the primary question is: why is nouveau even starting in the first place? It should output nothing & not 10 items.

What’s the output of this command?

cat /etc/modprobe.d/*

Shouldn’t commands like “nvidia-xconfig” work when nvidia driver is installed - even in qubes?

Good idea. I just put a file in it with this:

blacklist nouveau
options nouveau modset=0

And now it’s not loading anymore!

But the resolution is still wrong, the monitors are not recognized. Xrandr outputs this:
“xrandr: Failed to get size of gamma for output default
Screen 0:….”

On both different montors xandr outputs the same error.

Do you still have nomodeset kernel option?

Yes. Otherwise it’s again not working.

But doesn’t nomodeset just deactivate the standard thing until the x server is up?

Also there is a typo, it should be:

options nouveau modeset=0

Sorry! The typo exists only in this Forum; I’m currently using my tablet for research.

Hmm. When using the grapical installation & not the the cli command in the community guideline nvidia installer shows this:

For that i would have to stop lightdm, start the installer again & activate lightdm afterwards right? But how would that be possible because then this wouldn’t work anymore? ^^

Edit: Nevermind, the community guideline uses “—no-x-check” as a workaround.

Not sure how it works. I think it’s disabling kernel modesetting altogether and you can’t use the modesetting Xorg driver, only vesa/nv/etc Xorg drivers that may not support the resolution that you want:
https://wiki.archlinux.org/title/Kernel_mode_setting#Disabling_modesetting
Qubes OS is using modesetting Xorg driver by default.

Do you have any errors or it’s just stuck at the same screen as here?

Hm, okay. Interesting.

No errors, i am just sticking at the same screen as here.

Even if it lead to an error a few hours ago: maybe the error is the missing xorg.conf-file that is not generated?

You can try to configure xorg.conf as described here:

Finally, you should configure Xorg to use nvidia driver. You can use nvidia-xconfig or do it manually:

X -configure
mv /root/xorg.conf.new /etc/X11/xorg.conf
# replace Driver in Device section by "nvidia"

Well, now lightdm doesnt work again…

“Failed to load module “nvidia” “… :frowning:

Maybe you’ve installed wrong nvidia driver?
Or it’s failing?
Check the logs in journalctl, maybe there will be any info about nvidia.

I checked the driver, it’s the right one.

There are no errors:

I’m currently writing all infos together in the hope that something catches my eyes…

You already sent me this link: Stuck in a boot loop after entering Luks PW successfully - #2 by apparatus

Could it be possible that any setting of this could have fixed me issue when it worked once? On my understanding these are only logging configs that shouldn’t have any correlations with this, or am I wrong?

I created a new post here because I realized that this post was too general and already contains many different error fixes. If someone has a similar problem in the future, they will not find it here; hence the new ticket.

Thank you for your incredible support and for your patience! ^^ @apparatus

No, these options shouldn’t have changed anything except for enabling the log output.