Minimal Template installation fails in Qubes 4.1rc1

Hello there.
I have installed Qubes 4.1 rc-1 on my PC. I was already testing 4.1 previously with minimal templates for last 1 year but freshly installed release candidate 1. I tried to install debian 11 minimal template on RC.
qvm-template install --enablerepo=qubes-templates-itl-testing debian-11-minimal

It fails with Error: Download failed
cc @marmarek

Issue remains same even after 1 repeat install and with sudo qubes-dom0-update equivalent command.

It works for me… Do you get any more details if you add --verbose?

Even with --verbose Error output is same. Messages like these all I’ve got-

Downloading 'qubes-template-debian-11-minimal-0:4.0.6-202108191622' ... 'qubes-template-debian-11-minimal-0:4.0.6-202108191622: 0% 0.00/225M [00:00< Error: 'qubes-template-debian-11-minimal-0:4.0.6-202108191622' download failed.

I have tried with Clearnet, Whonix (default repos and Onion repos both). So definitely not an issue with my network. As everything else working like updates of Debian-11/Fedora-34, browsing in VMs and Whonix-ws-dvm etc.
I have also tried fedora-34-minimal with same luck.

Hi @mebraska ,
You don’t use the good package name (missing the qubes-template- prefix), see the template package list from the templates-itl-testing repository.

Sometimes I have to repeat it because it’s just a bad connection.

Have you tried RC1?
The usual command for template install redirects to qvm-template now and it doesn’t include qubes-template.
Anyways, It doesn’t get downloaded either way.

I can confirm that qvm-template --enablerepo qubes-templates-itl-testing install debian-11-minimal works for me

I also get the same error, unfortunately this will not download.

Can you retest with sys-tor ? I confirm that this problem is because dom0 updatevm is using sys-whonix, change network to sys-firewall works fine.

With sys-whonix, update and install package is work, only qvm-template isn’t working.

Try change dom0 updatevm to sys-firewall.

I am using sys-whonix and onionized repositories for all updates. And It’s definitely not working.

Unfortunately, this is still not downloaded.

1 Like

hmm then this is weird, try using sys-whonix, would that do ?

Any way to debug this, @marmarek?

There seems to be a major issue in trying to use Whonix as an updateVM,
both for dom0 and for templates.
It is not restricted to use of onion repositories.
You could debug this by tracing the flow within sys-whonix: I don’t use
it and am not familiar with the update mechanism there.

I reinstalled Qubes again today and selected Fedora 34 as the default template. This allows me to download and install the Debian 11 minimal template and the others. On another PC I repeated the whole process and selected Debian-11 as default template and there I could not download the templates again. So it looks like the problem is related to the default template selection under Debian-11.

Can you run qvm-template install with sys-whonix ? or it’s only work with sys-firewall like i said before ? btw i don’t install debian 11 in initial config.

With sys-whonix I get the same error message that it cannot be downloaded. On both PCs with Debian-11 and Fedora-34 as default template.
Only on the PC where I have selected Fedora 34 as the default template in the initial config, I can download the templates via sys-firewall.

Then we can assume :

  • debian-11 as default template in initial config; will lead qvm-template error (i don’t know with qubes-dom0-update).
  • fedora-34 as default template in intial config; qubes-dom0-update is work, qvm-template not work (sys-whonix only)

If anyone wanna test it, please do it with 4.1rc1, I can confirm and remember that with 4.1 beta i don’t have these problem.

I have done multiple installs with different configurations and it never worked for me.
I have tried only fedora-34 template install and trying it with sys-firewall
All templates install and with sys-firewall or with sys-whonix
I also tried it with latest weekly build (today) and same results
I was previously running Qubes 4.1 test builds from @fepitre and there was no issue. My last working build was with whonix 15 and qubes-core-admin 4.1.21
This is definitely something which needs to be solved, but I am not skilled enough to debug it myself. Help is really needed here by some dev.

I’m also experiencing the same issue (not being able to install TempateVM’s via qvm-template) - not only with minimal TemplateVM’s but all of them.
All of my qubes are based on Debian 11 or Whonix 16. sys-whonix being UpdateVM for dom0 package updates are possible and everything else seems to work as expected.

Edit: new post includes everything