Logging in to CUPS - user password?

I’m trying to get printing and scanning via bluetooth to work. I can see the printer in blueman and can pair with it; I have also set it up via system-config-printer, which can detect it. But the print jobs won’t print.

System-config-printer troubleshooter tells me to set the “Enabled” policy in CUPS admin tab. So I go to “localhost:631” (CUPS interface) and select “Administration” tab, where it asks for my username and password; the former is “user”, but the latter? I tried “password” as well as leaving it empty, but that does not work. Does anyone know how I can log in to CUPS inside a QubesOS VM? Or any other tips?

FWIW usb printing and scanning with a different printer from the same qube works.
Edit: printing also works via usb with this particular printer for which I want to get bluetooth printing working and also from the same qube.

Ah the answer is so simple: start firefox as root…(sudo firefox)…I’ll test printing later but for now this problem of how to access CUPS admin section is solved.

I don’t think this is so simple :wink:

And this even sounds quite strange to me! Why would this change something since CUPS is accessed through a TCP/IP socket? :thinking:
CUPS knows that you connect locally through the loopback, but this looks quite weak to me.

I don’t understand what your points are, t.b.h; all I know is that I couldn’t access the admin tab of CUPS using localhost in firefox, but when starting firefox with sudo I can access it.

Sorry if my remark wasn’t understandable. It was not a criticism of what you wrote, nor that I was doubting.

It’s just that from my “security point of view”, I don’t understand what change CUPS sees between the 2 connections to the “locally remote” port 631…

Frequently Asked Questions - CUPS.org states that you must provide a password.

No worries; I don’t understand it either, but since it works, I’ll run with it :smiley:

I do this in a disposable VM that is not connected to the network, so security-wise the down-sides seem to be quite limited.

It sounds like a permission issue. Could you please try this:

sudo usermod --append --groups lpadmin user

user => your username

Or try this.

1 Like

Hmm now my “fix” using sudo stopped working for some reason; I tried your suggestions, but for the quoted line it just says “usermod: group ‘lpadmin’ does not exist”, while in the linked thread I followed the instructions (including using HTTPS), but it still asks for username and password, which IIUC is expected, as it says at the bottom there that the site will ask for username and password, but that’s exactly what I don’t want…passwd isn’t even installed on the fedora template.

I’ve removed my own “fix” as the solution since it doesn’t work anymore; if anyone has any ideas, I’m all ears.

CUPS is weird. The way I do it is:

sudo passwd
#then type like 123  as the password

Then on the CUPS website you put “root” as the user and “123” as the password.

Yeah, you’ll need this at least with my fix


Chosen as solution, as I’m installing other stuff in that template anyway because of the printer / scanner software etc., so I don’t mind one more package and it seems to reliably work.

Thank you.

1 Like