Libxenlight failed to create new domain

Hardware details

My laptop is a Asus GL552VW.

I’m trying to run a qube. Any qube. Not one can run.

The error I keep getting is this:

Qube Status: sys-net
Qube sys-net has failed to start: internal error: libxenlight failed to create new domain ‘sys-net’

It’s not telling me about any error logs, and I also don’t know how to obtain any error logs. If you explain how I can obtain them, I’ll upload them here. Sorry, a newbie here.

Did you enable VT-d in your BIOS?
Are you able to start offline qube (with net qube set to none) e.g. vault qube?
Check the log in dom0 for additional info about the error:


Yes I am.

It just tells me “bash: /var/log/libvirt/libxl/libxl-driver.log: Permission denied”. I’m meant to type that into the “Xfce Terminal” under dom0, correct?

Run in dom0 terminal:

cat  /var/log/libvirt/libxl/libxl-driver.log

Still saying cat: /var/log/libvirt/libxl/libxl-driver.log: Permission denied

I didn’t change any of the default settings when installing besides making an Admin account (which is what I’m logged into obviously), so I’m not sure why I’m getting permission denied.

I forgot to add sudo:

sudo cat /var/log/libvirt/libxl/libxl-driver.log


I apologize for my ignorance on this matter.

Logs (Images)

Open first dom0 terminal and run this command there:

sudo tail -f -n0 /var/log/libvirt/libxl/libxl-driver.log

Open second dom0 terminal and run this command there:

journalctl -f -n0

Try to start sys-net.
When it fails make a photos of the command output in both dom0 terminals and post here.


Logs (Images)

Sounds cynical but this is a Whonix Gateway question and should ask Pee Schvantze on the appropriate forum. I had these type of problems so many times that I jailed break my Whonix at least 2 years ago and I will never go back.

Try this: Create a dvm based on Gateway (connected to sys-firewall) and don’t start it. Start a disposable based on the gateway-dvm and see if you have the same results.

What’s the output of this command in dom0?

sudo cat /var/log/xen/console/guest-sys-net-dm.log

I think you’ve posted this in the wrong topic.

Maybe something gone wrong during Qubes OS installation, you can try to reinstall Qubes OS, it seems that it helped someone with the same issue:

Or you can try to use kernel provided by template in sys-net:

1 Like

I posted in the wrong topic above… that one was for Tor. Got called someplace.

For this topic it has to do with the kernel. Somehow sys-net kernel was restored backup and there is no corresponding kernel in dom 0. It is a tough one to restore from backup without the correct kernel. It has to do with your hardware too. If you still have the “infected” machine make a backup with the lowest kernel and try again.

1 Like

If you have i2p ask on retrobbs.i2p/i2p and I will post the latest and greatest Debian 12 updated that might work for your case. Again the hardware is the problem.

Did you get the libxenlight-error during the post-reboot setup screen? Or later during use?
There is something weird going on with the installer. I got the same error and fixed it by using an older installer.

1 Like

So I did reinstall it and it did work. I’m a bit confused because I used the same ISO file, same USB, same computer, etc, and there was zero differences from what I can see from my third attempt reinstalling it. I guess I shouldn’t question it; it seems to be working currently.

It was after installing and booting up the system, I kept getting an error about a PCI device. I fixed it by using this here, but after fixing that issue I then got the Libxenlight error.

So it was immediately after installation, I hadn’t actually used Qubes OS yet in this stage, but it wasn’t the first error I got after boot up, if that makes sense.

Thank you @oxygenlast & @apparatus for suggesting I reinstall it, it seems to of fixed it (at least for now).

1 Like