Lenovo Thinkpad X1 Carbon (Gen 12)

I’m trying to install qubes 4.2.1 on a Thinkpad X1 Carbon gen 12, and after installation and initialization is complete, the lightdm login screen does not display.

I’ve tried rebooting and after unlocking the luks drive it gets stuck at this unlock screen, but I can get to the tty login using ctrl + alt + f2.

I tried to change the xen configuration according to this document but still can’t get to the gui desktop properly.

Hardware specific information (I can’t copy hcl, right now):
cpu intel ultra 7 155H
gpu: intel arc graphics
qubes: 4.2.1
xen: 4.17.3
kernel: 6.6.21-1


Did you finish the Initial Setup step:

Or you do have this issue with display right after installation is finished here:

And you boot in Qubes OS the first time?

You can switch to another tty with ctrl + alt + f2, login and check the logs there:

journalctl -b -u lightdm
journalctl -b

To find the error.
Maybe the kernel is too old for your hardware and you need to update it.


Thanks for the quick reply, I completed the installation according to the installation manual.

Also not having problems with the installation progress page.
It is after this screen is complete that I am having problems with lightdm not being displayed.

I don’t see any error logs related to lightdm via systemctl status lightdm and journactl -b, but I do find these logs of i915 initialization failures and kernel version prompts.

I’m looking at the archlinux wiki Intel graphics - ArchWiki Maybe I can try upgrading to a 6.8 kernel using the xe driver and try again.

You can try to install kernel-latest from current-testing Qubes OS repository using tty.
Download the kernel package from another system:
Mount your Qubes OS root in another system or from offline Live OS and move the package to dom0.
Boot into Qubes OS and in tty verify package signature like this:

rpm -K /path/to/kernel-latest-6.8.8-1.qubes.fc37.x86_64.rpm

Then install it:

rpm -i /path/to/kernel-latest-6.8.8-1.qubes.fc37.x86_64.rpm

Thank you very much for the method, I’ll find an Ubuntu 24.04 livecd and try to install the latest kernel to see if I can get to the login page properly.

Now that I’ve updated to the latest 6.8 kernel, I’m currently able to access the desktop system properly, thank you very much for your help.

I’m currently working on fixing the wifi issue, and I’ll update the exact steps and HCL report when the functionality testing is complete!

HCL Report
Qubes-HCL-LENOVO-21KC0000CD-20240501-134001.yml (781 Bytes)

Matters requiring attention

Need 6.8 kernel to be able to properly access the login UI (lightdm), it is recommended to use fedora for the default template, the firmware in the default debian template is too old resulting in the wifi not being driven correctly.

Test Functional Items


Mute Work
Volume up or down Work
Mute microphone Work
Brightness Up/Down Working
Display Settings Shortcut Keys Work
Performance Mode Selection Not Working
Screenshot Shortcut Work
Area Screenshot Not Working

Hardware Device Class

Microphone Working
NPU not working
Mobile broadband working
TouchPad working
Audio working
TrackPoint working
Fingerprint reader not tested
Wireless Jobs

Reference Links Lenovo ThinkPad X1 Carbon (Gen 12) - ArchWiki

I think you should also add “HCL Reports” category to the topic and add the link to HCL report in the first post. Otherwise some users won’t find it.
Or maybe it’d be even better to create a separate topic for HCL report.