Lenovo Thinkpad X1 4th generation not starting after completed the install (4.1.2)

I was able to install version 4.1.2 and that all went well.

After the notification to remove the installation medium (and I removed the usb drive). the laptop freezes up.

When restarting Qubes is not loading.

Thanks for giving me help and possible solutions!

Why did you install Qubes OS 4.1.2 instead of Qubes OS 4.2.1?
Qubes OS 4.1 will be EOL in a few months.

If I remember correctly I wasn’t able to get the installation going. Perhaps give that another try eh? Is that what you would recommend? I appreciate you giving me pointers! -Yan

I’d recommend to try and fix the Qubes OS 4.2.1 installation, because Qubes OS 4.1.2 won’t be supported anymore soon and there is no point in using it. Only if you wanted to check whatever you could install it successfully for a test.


In trying to install Qubes OS version 4.2.1 the installation won’t start. Black screen and stuck. What is your recommendation?

What’s your hardware (CPU/GPU)?

Laptop has i5 processor

Intel HD Graphics 520 in processor

Can you add these command line options to kernel and Xen in installer GRUB menu to see the debug output if there will be any?

A little bit of time relay in between. Thank you for your help.

I do see a lot of information via the logs …

the install seems to stall with …
[0;32m OK [On] Started [0;1;39msystemd-journald.service [0m Journal Service.

No idea how to proceed?

Need more info from the log. Can you make a photo?

Disable Xen logs and only leave kernel logs in GRUB like this:
For kernel command line (first module2 line) add: console=hvc0 plymouth.enable=0 panic=0
For kernel command line remove plymouth.ignore-serial-consoles rhgb quiet
Maybe there was some relevant info before the logs on photo but it was overflown with Xen logs.

Yes, this did the trick! Installed now and onwards to the next step of getting familiar with QubesOS. Very grateful for your assitance, thank you much!

1 Like

When trying to fire up some cubes, the operating system gives the error: 'Qube (sys-net/ sys-firewall/ personal) has failed to start: Failed to start an HVM qube with PCI devices assigned - hardware does not support IOMMU/VT-d/AMD-Vi

How could this challenge get resolved @apparatus ?

You need to enable VT-x and VT-d in BIOS.

That’s probably the same as ‘visualization’, correct?

Configured that, and now it seems to be working (slow) …

It depends on the vendor BIOS and it could be called differently.
It could be called like this:
VT-x - Intel Virtualization Technology
VT-d - Intel VT-d Feature
Check your laptop BIOS manual.

I notice 2 things:

  1. the system is pretty slow, will adding 16MB of ram improve this
  2. it doesn’t look like all standard cubes are installed (see screenshot), how could this get solved?