Lenovo ThinkPad E595 boot failure

Hello, I came here not in search of a solution but to report a non-working device, because I truly believe there is no salvation for me.
I have been trying to install Cubes OS (4.2.0) on my old Lenovo ThinkPad E595. Virtualization is enabled, and secure boot is off. So far I have tried these:

  • install with Automatic disk partitioning - failed to boot
  • install with custom disk partitioning and tried both LVM options and the standard (non-brfs) option - failed to boot
  • rescue system with USB after installation - Anaconda either can’t find any Cubes OS installation or gives an error about there being more than one disk partitions named dom-0
  • Install Windows 10 and apply all the BIOS and firmware updates and reinstall Cubes OS - Failed to boot

I honestly think that my device is not made for this, which is kind of weird because similar devices (with Intel instead of AMD) from Lenovo in the similar timeframes reported to work in the compatibility list.

But I didn’t want to jump the gun and add the Lenovo ThinkPad E595 as a non-working device before I posted it here. Maybe I’m doing something wrong.

@flavio Just in case this is worth a note in the HCL? (To be clear: I don’t know if it is, but I jnow you will!)

Good question! I wish I knew how to report this. If it doesn’t run, there is no HCL generated. The E570 seems to work fine. Perhaps it has something to do with the UEFI configuration. Is there a selection on the BIOS to choose BIOS vs. UEFI in that model?

Do you mean legacy vs UEFI? Yes, I tried only legacy and only UEFI as well, I forgot to write that detail.

Describe in more details how exactly and at what stage did it fail to boot.

It doesn’t even get to the GRUB, It kicks me back to the BIOS hard disk selector. So there isn’t much I can say really.

Did you install Qubes OS on external drive (USB?)?

Also check the boot order in BIOS to make sure that you’re booting fro the correct drive.

Did the install give an error about failing to add UEFI entry?

Could you try this:

  • Plug the installer USB (?) into the computer and a select that as boot-device
  • When it shows the menu to Install Qubes / Test media / … press c to get the GRUB prompt
  • Enter:
configfile (

and hit TAB

Do you get a single hd0 or both hd0 and hd1 (or more)? If you get 2, thy to with:

configfile (hd1,gpt1)/EFI/qubes/grub.cfg

(you should be able to use TAB to complete the path).

If that command gives you a GRUB menu with options like “Qubes, with Xen hypervisor” / “Advanced options for Qubes (with Xen hyperviser)”, just pick “Qubes, with Xen hypervisor” and let us know if it boots. :slight_smile:

I installed it on a hard drive, not a USB.
I changed the boot order many times unfortunately, it doesn’t change anything.

Was your last Qubes OS installation in Legacy or UEFI mode?

I got three hd’s, unfortunately executing the command configfile (hd1,gpt1)/EFI/qubes/grub.cfg didn’t add anything to the GRUB prompt.

I tried with both, disabling the other. Neither did work.

Oh - with 3 hd’s, try with each of:

configfile (hd0,gpt1)/
configfile (hd1,gpt1)/
configfile (hd2,gpt1)/

and hit TAB to see if one has a EFI folder - and repeat for:

configfile (hd0,gpt2)/
configfile (hd1,gpt2)/
configfile (hd2,gpt2)/

configfile (hd0,gpt3)/
configfile (hd1,gpt3)/
configfile (hd2,gpt3)/

If you find a EFI in one of them, then check if there is a qubes folder inside …


configfile (hd2,gpt1)/EFI/qubes/grub.cfg did it. I’m in qubesOS right now. Thank you. So how do I make this permanent?

Great news, that you were able to locate the Qubes installation - and that it’s working! :slight_smile:

I don’t have your hardware, so I’m only guessing … but it could be a matter of renaming some folders, as @apparatus linked yesterday:

or since it was on hd2, maybe the BIOS only look at hd0/hd1?

Since you have three harddisks, is there another OS, that you need to be aware of?

Yes there is another OS, I needed to update some firmware so I installed Windows 10 to do just that however before installing Windows 10 I tried installing Qubes OS on both hard drives, what makes me confused though is there being three hard drives in that selection. I remember installing manjaro like 6 years ago and not being able to uninstall it clean. It still showed up in BIOS like it was a disk of its own and I thought I removed it completely from BIOS as well, alas it’s probably still there despite not getting shown in BIOS.

If you have 2 harddrives, then the 3. hd was probably the USB installer, acting as a harddrive. :wink:

If you don’t care about the Windows installation, then you can try different settings – if you had important files on the Windows installation, then you would need to be carefull with the commands (Linux will do as you bideven if the result is, that you loose everything!).

It sounds like you have EFI-boot - could you try:

sudo efibootmgr

in a dom0 terminal? If you get something with

BootOrder: xxxx,yyyy,zzzz
Bootxxxx* Qubes OS
Bootyyyy* Manjaro

then search the forum for efibootmgr to see if there is an example that looks somewhat like your situation - or Google for examples for efibootmgr. :slight_smile:

Ok, the permanent fix is done, and works flawlessly. Thank you all for everything!

I did that just now and there is no manjaro, thankfully. I completely forgot about the USB haha that should be it.