Large Monitor and dom0 resources

Hi All,

I just installed a very large monitor and it seems everything is much slower.
The slow down includes qubes starting and stopping, video rendering, even web pages are extremely slow compared to before.
Is there anything I can do about it?
Does dom0 need more resources dedicated to it?

It is a large 43" monitor. 3840 x 2160.
My work requires a lot of screen space and my previous Windows setup had 4 22" monitors, so this replaces them all:

I am running a Librem Mini v2 with the following specs:
Processor: Intel Core i7-10510U (Comet Lake), 4 Cores, 8 Threads, up to 4.9GHz
Graphics: Intel UHD Graphics 620
Video: 1 HDMI 2.0 4K@60Hz, 1 DisplayPort 1.2 4K@60Hz
My RAM is 32GB, DDR4-2400, 1.2V DDR4 L2133/2400MHz
And my storage is 2 drives:
250 GB, M.2 SSD and 250 GB, 2.5" SSD


more then likely its the intel driver that may be needed to be updated and I would be using the “display port” instead of the HDMI. As the HDMI requires more bandwidth because it will pass audio as well as video.

Thank you. I’ll look into how to update the Intel driver.
Thanks for the scoop about DP vs HDMI too.
I set the vm I was testing to have all 4 cores instead of the default 2 and things improved a bit. But I don’t yet understand the full implications of that, nor whether it’s wise to do that for other qubes.
I also gave it more ram. Lots to learn. :slight_smile:

@JwS … on the one hand I have seen @Demi talk about that driving a 4K
screen is a challenge since Qubes OS uses software rendering. She is
deep in the code and part of the core team, so I don’t doubt there is
truth to it.

On the other hand I have been using a 4K monitor with my ThinkPad P51
(HD 630 Graphics) for months and never seen any performance penalty
except maybe when going full screen with a Netflix or Prime video.

And this week I started using a ThinkPad T430 with a far less powerful
CPU and HD 4000 integrated graphics. Here I can see maybe a very slight
performance impact, but on the other hand the fullscreen Netflix seems
to be more smooth and clear than with the P51.

In any case, with both machines 4K only works on DisplayPort for me. I
can’t even get to 4K resolution using a HDMI cable.

Not sure this was helpful to you. But switching to DisplayPort might be
the solution to your troubles – I’d definitely try it.

Hi @JwS ,
just an idea, maybe I’m wrong, but in the BIOS settings, try to give more memory to your intel GPU.

Thanks Sven and ludovic, I have the monitor plugged into the DP now. I’ll look into the BIOS settings.