Laptop 4.2 Installation - Failed to Start system-udev-settle.service

I am trying to Install Qubes 4.2 on my laptop:
RTX 3050

I got Intel VT-d & Intel VT-x Enabled.
I tried installing via regular, live boot, and kernel mode
all show the same error message:
“Failed to Start system-udev-settle.service - Wait for udev to Complete Device Initialization”

After about 30 minutes or an hour there is a screen that looks like the “tree” command in windows CMD, and then a message “Boot failed” or something similar.

What is the problem? Thanks.

Hi Wrt – and welcome to the forum! :slight_smile:

“RTX 3050” … that’s a Nvidia GPU … right?

I had a quick look at the HCL1 and spotted a laptop with that GPU and a description of some GPU settings:

… maybe they apply to your model/make as well?


Looks like the problem in the topic is old (2022) and might be already fixed on 4.2:
This section might be irrelevant in the future when Nouveau fully supports the RTX 3050ti mobile
And they have rendering issues: “default installation results in a black screen”
not similar to the problem I have

Yes - nouveau might have support for the 3050 now … and it might not … :-/

I don’t have your hardware and I don’t recall “Failed to Start system-dev-settle.service”, so I’m trying to eliminate possibilities … Can you try to remove quiet from the kernel line and see if more information should be available?


Okay… just did and it started showing “nvme0 timeout completion polled” around the [FAILED] Failed to Start system-udev-settle.service error, I goggled it and disabled hyperthreading in bios. Same issue still.
Note, I can’t take out the NVMe, dont want to void laptop warranty. and I am planning to install Qubes on an external SSD.

This post suggest some RAID / VMD issues:



Okay… it fixed the udev prob, but now I have this:

How did you write/make the installation media?


Rufus using ISO image mode

Sounds/looks similar to this old case?

– and that is linked from:

Maybe writing the ISO with a different tool, can resolve the problem?

Note: I’m guessing, but hope it can point you in the direction of a solution.


Going well now. Thanks.