Internet access Standalone Ubuntu Qube

Hello dear community :slight_smile:

I have successfully installed an Ubuntu standalone, the only thing that I cant seem to get working is internet access… Ubuntu 22.02 confirms connection but loads no pages…

all my other Cubes have normal internet access either with a VPN-cube or default networking…

I used the network configuration from my sys-firewall cube, So I entered IP, Netmask, Gateway and Virtual DNS numbers and added them in the Ubuntu standalone, I get it to connect, but I still am unable to reach any website.

I want to use this Standalone as my “self-hosted” server, I also tried Ubuntu server Template and standalone, but i keep facing the same problems…

Since Ubuntu is one of the most well documented OSes and runs servers pretty good… I intent to try that first…

I would favor a Qubes debian / fedora server as well but had no luck getting that to work.
The reason I have given up on Qubes debian / fedora server is messing with qvm firewall…
I`d be normally using tutorials and copy/paste the required information, this is why I installed a standalone, to use UFW firewall instead…

thank you :smiley:

Follow the guide:

But change netmask to 255.252.0.0.

1 Like

Hello!

Thanks for your fast reply! The link you provided states the things I tried. I also tried changing the netmask which didn`t help :frowning:

im referring to the IPs in the networking section.

Where did you configure the network settings?
Can you try to ping some IP address from your HVM?

ping 9.9.9.9

I entered them in the Ubuntu HVM. same like you would configure normal Ubuntu install (pressing wireless symbol and then edit connection from there)

I checked my network configuration to make sure the Ubuntu VM network is set to sys-firewall or VPN cube.

I can`t ping either, terminal stays blank or empty…

Post your HVM network settings from its Qube Settings window and output of these commands in HVM terminal:

ip a
ip r
cat /etc/resolv.conf

Here is it is:

Terminal output:

user@user-HVM-domU:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 00:16:3e:5e:6c:00 brd ff:ff:ff:ff:ff:ff
inet 10.137.0.6/14 brd 10.139.255.255 scope global noprefixroute eth0
valid_lft forever preferred_lft forever
inet6 fe80::bc93:d2d9:a00a:461b/64 scope link noprefixroute
valid_lft forever preferred_lft forever
user@user-HVM-domU:~$ ip r
default via 10.138.7.19 dev eth0 proto static metric 20100
10.136.0.0/14 dev eth0 proto kernel scope link src 10.137.0.6 metric 100
169.254.0.0/16 dev eth0 scope link metric 1000
user@user-HVM-domU:~$ cat /etc/resolv.conf

#This is /run/systemd/resolve/stub-resolv.conf managed by man:systemd-resolved(8).
#Do not edit.

#This file might be symlinked as /etc/resolv.conf. If you’re looking at
#/etc/resolv.conf and seeing this text, you have followed the symlink.

#This is a dynamic resolv.conf file for connecting local clients to the
#internal DNS stub resolver of systemd-resolved. This file lists all
#configured search domains.

#Run “resolvectl status” to see details about the uplink DNS servers
#currently in use.

#Third party programs should typically not access this file directly, but only
#through the symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a
#different way, replace this symlink by a static file or a different symlink.

#See man:systemd-resolved.service(8) for details about the supported modes of
#operation for /etc/resolv.conf.

nameserver 127.0.0.53
options edns0 trust-ad
search .
user@user-HVM-domU:~$

Why did you set the qube IP to 10.137.0.6 when it should be 10.137.0.12 based on its network settings in qube Settings?

seems it was a typo…It was configuration from another Cube :smiley: I have missed that completely

thank you very much!