Insufficient privileges

I’m trying to create a VPN Qube in a passwordless root Debian 12 minimal environment.

Using Mullvad VPN in Qubes | Micah Lee - ctrl f and search “Back in your file manager, double click on” to see where I’m at. Import a saved VPN configuration.

When I click “Save”, it gives me the insufficient privileges prompt. How do I get privileges for this? I’m unsure if it can be done from the cmdline, and I’d rather stay passwordless if possible.

1 Like

Right click on the file and see who owns the file you’re trying to open. But you might be way off course- you prob shouldn’t be using the minimal template or debian for that matter since your guide is recommending fedora.

And plus thats an old guide…I didnt read the whole thing so I might still work but you might want to use the one in the community guide section written by solene (I used it and it worked like a charm). There’s also a ready-made Mullvad cube you could try.

Looked at Solene’s guide, got “Authentication is required” (needs a password), but I get the VPN config in the menu this time. Any way I can bypass this or am I going to have to figure out how to add a sudo password?

1 Like

You can open the NetworkManger connection editor with root permissions by running nm-connection-editor in qubes root terminal.


Alright I’ve got it made but it doesn’t let me connect via nm-connection-editor, only takes me to the edit connection

Actually I might’ve fixed it, accidentally removed the eth conn so I’ll have to get that back to try it first