Installing the kali community template

i have tried the .rpm file from Index of /r4.1/templates-community-testing/rpm/ but i found no way of moving it to dom0 i also tried the sudo qubes-dom0-update --action=install qube-template-kali command but i get an error saying no match for argument qubes-template-kali

I have also tried sudo qubes-dom0-update --enablerepo=qubes-templates-community-testing qubes-template-kali with the same results as the previous command

1 Like

First, check your connection if there’s no problem then :

This normally means you already have the template installed. It may be that you have the matching package installed, but you removed or renamed the template. Check rpm -qa qubes-template\* . If it lists the package, but you don’t really have the template present ( qvm-ls doesn’t list it), you need to clean up leftovers of the package with rpm -e --noscripts qubes-template-<name> , then install it normally.

the rpm -qa command returns nothing

hmm it’s weird, can you install this ? i just want to make sure.

sudo qubes-dom0-update --enablerepo=qubes-templates-community-testing qubes-template-centos-7

interrupt the update if you can.

yes but not kali for some reason

okay that mean you using qubes os r4.0 the package is meant for r4.1
if you want, you can use this package :

download in some vm then install in dom0 :

[user@disp-2134] cd ~/Downloads
[user@disp-2134] wget ## kali for r4.0 builded by unman 

[user@ dom0] qvm-run --pass-io <src-vm> 'cat /path/to/file_in_src_domain' > /path/to/file_name_in_dom0 ## send file from vm to dom0
example from above command 
[user@ dom0] qvm-run --pass-io disp-2314 'cat ~/Downloads/qubes-template-kali-4.0.6-202106091045.noarch.rpm > ~/qubes-template-kali-4.0.6-202106091045.noarch.rpm
[user@ dom0] sudo rpm -i ~/qubes-template-kali-4.0.6-202106091045.noarch.rpm

2 posts were split to a new topic: What is the website?