Installing Qubes to USB, not bootable and not recognisable by OS

Hello guys,

I’ve been trying to make a portable USB OS using Qubes with Whonix.
I’ve created a bootable installer media from the .iso using Rufus which boots and runs great. Following the “Installation Guide” on qubes’ site, I chose my 32 GB usb drive as location. The installer works well finishes the installation. However, when I try to boot from the later USB drive, it doesn’t show up in the bios. I’ve changed UEFI/ Legacy support but still no luck.
In the qube’s site UEFI Troubleshooting section it mentions under " Boot device not recognized after installing"

  1. Copy the /boot/efi/EFI/qubes/ directory to /boot/efi/EFI/BOOT/ (the contents of /boot/efi/EFI/BOOT should be identical to /boot/efi/EFI/qubes besides what is described in steps 2 and 3):
cp -r /boot/efi/EFI/qubes/. /boot/efi/EFI/BOOT
  1. Rename /boot/efi/EFI/BOOT/xen.cfg to /boot/efi/EFI/BOOT/BOOTX64.cfg :
mv /boot/efi/EFI/BOOT/xen.cfg /boot/efi/EFI/BOOT/BOOTX64.cfg
  1. Copy /boot/efi/EFI/qubes/xen-*.efi to /boot/efi/EFI/qubes/xen.efi and /boot/efi/EFI/BOOT/BOOTX64.efi . For example, with Xen 4.8.3 (you may need to confirm file overwrite):
cp /boot/efi/EFI/qubes/xen-4.8.3.efi /boot/efi/EFI/qubes/xen.efi
cp /boot/efi/EFI/qubes/xen-4.8.3.efi /boot/efi/EFI/BOOT/BOOTX64.efi

How can I do the above when I have no access at all to the drive afterwars?
In windows it’s not even recognisable as a drive.

Don’t use Windows. Use a live distro running from another USB, and this
will allow you to access the source and the drive.
Pretty much any live image will work for this, as the tools are basic linux commands.
You can find a variety of live images to use - there’s a hefty Fedora
live, Debian live, or much more lightweight versions like Porteus,MX. You
should be able to get one of these up and running in next to no time.

to add to that, you can even use the qubes install iso - boot the installer wait for it to get to the grpahical ui, then type ctrl+alt+f2, should then give you a terminal you can type commands in.

after you boot with a live iso, plugin the usb with your qubes install, then run lsblk -f look for a vfat partition on the usb. thats you efi partition. mount it and you should see a EFI directory at the root.

Thanks for the replies.
I made a live mx USB and booted from there.
Here I can access the USB with Qubes installation.
It appears as two volumes, how ever they are read only and the folders mentioned seems to be missing. I tried with terminal commands and I copy the files but still no luck.
I took some pictures to show you.


Also I tried the LS command and the vfat I get is my NVME and the live cd.
I feel I’m doing something wrong here but I’m not experienced Linux user.
Thanks for your help guys.

moderation edit: replaced image links with images hosted on the forum


moderation edit: replaced image links with images hosted on the forum

(Hi @matzis, just a quick tip. You can upload pictures on the forum, I’ve edited your posts to reflect that - and to avoid rotten links)

Thanks for this, however when I tried to upload them it would state “New users at limited to 1 image per post”

Ah. I see!

based on your image, your usb doesnt have an efi partition.

probaly best to just reinstall onto the usb and make sure you add a efi system partition, with mount point /boot/efi. also recommend reinstalling because your lvm isnt encrypted (unless you want it that way)

sdb is your usb

sdb1 looks like your /boot

sdb2 looks like your lvm that holds the qubes install

what you want is

sdb1 /boot/efi [vfat] ====> efi sys partition
sdb2 /boot [ext4] ======> qubes boot partition
sdb3 [luks] ===> lvm ==> qubes_dom0… ===> encrypted qubes install