Installing nvidia proprietary driver for dom0

Hi,

I pushed an update for the community guide explaining how to install the nvidia driver on dom0, Update install-nvidia-driver.md by rapenne-s · Pull Request #262 · Qubes-Community/Contents · GitHub

However, I was curious to know if people are using the kmod solution with success, it recommends using Fedora 18 which make me thing it may not be used regularly…

(that’s also the opportunity for me to make a thread about a successful nvidia driver installation and help future users, because the forum didn’t have any from my search :smiley: )

1 Like

Is there any reason to install the nvidia driver in dom0?

I tried installing it for the 1060, and the card doesn’t work with Xen. Don’t know if it’s only an issue with the old cards, but at some point nvidia changed the driver in a way that made it stop working with Xen.

You can’t really use the GPU in dom0, and in terms of just basic video output I don’t know if the nvidia driver is better than the nouveau driver.

I use a 1060 and it’s fine with the driver. I have a 144 Hz screen and that doesn’t work with the nouveau driver, + it feels sluggish with nouveau in general.

Maybe they fixed it.

I was getting the same error from the driver as reported here, https://groups.google.com/g/qubes-users/c/v26zXkiNElg

The official nvidia response to the issue is that Xen isn’t supported.

Oops, it’s there Contents/docs/configuration/install-nvidia-driver.md at master · Qubes-Community/Contents · GitHub

I don’t see a reason to use NVIDIA in dom0 at all, unless it’s the only GPU?
For testing purposes, I installed both nouveau and proprietary drivers several months ago without problems. I just remember that on of them gave only a single resolution in dom0.

I just tried using the guide for 4.2

I couldn’t blacklist the nouveau driver without making a modprobe.d config file, and running dracut --force. This completely disabled video output until xorg was started, to restore graphics during boot I had to add nosplash nomodeset to grub.

I didn’t try with 4.2, I replaced my card by something that doesn’t require proprietary drivers in the meantime :sweat_smile:

Thanks for reporting this, is this ok with the nosplash now?

Yes, it works. It technically also works without, but you can’t see anything until the driver loads, and you need to enter the LUKS password blind.

1 Like