Installing KDE? Everything downloads but stays cached?

I was able to just install KDE i think it was in 4.1 rc2 but I wiped my machine and installed rc3 (its my tinkering box) and tried to install KDE the same way, in dom0 running:
sudo qubes-dom0-update @kde-desktop-qubes
but this time it seems to download everything and then the window closes, when i reboot and try to select KDE at the login screen I still only have xfce as an option and when i try to reinstall kde i get output that downloads are skipped because they are already installed and will be saved in cache? not sure where to go next with that?

For what its worth, after the download term window goes away, I am left with the error:

Module or Group “kde-desktop-qubes” is not available

As i mentioned before, I was able to install it in rc2 i think, any reason it shouldnt be working in RC3?

there similar know bug in qubes 4.1, not sure if it fixed

ah, well that would explain it. Thanks for the heads up!

@stumpi KDE is great in 4.1 But you need to install it differently than the official docs instructions.

Use the following:

sudo qubes-dom0-update apper breeze-icon-theme colord-kde dolphin kcm_systemd kde-runtime kde-settings-pulseaudio kde-style-breeze kdelibs kdeplasma-addons kdialog khelpcenter khotkeys kinfocenter kmenuedit kmix konsole5 kscreen ksysguard kwin phonon-qt5-backend-gstreamer plasma-breeze plasma-desktop plasma-desktop-doc plasma-pa plasma-user-manager plasma-workspace polkit-kde qt5-qdbusviewer sddm sddm-breeze sddm-kcm sni-qt

And then reinstall the same thing immediately:

sudo qubes-dom0-update --action=reinstall apper breeze-icon-theme colord-kde dolphin kcm_systemd kde-runtime kde-settings-pulseaudio kde-style-breeze kdelibs kdeplasma-addons kdialog khelpcenter khotkeys kinfocenter kmenuedit kmix konsole5 kscreen ksysguard kwin phonon-qt5-backend-gstreamer plasma-breeze plasma-desktop plasma-desktop-doc plasma-pa plasma-user-manager plasma-workspace polkit-kde qt5-qdbusviewer sddm sddm-breeze sddm-kcm sni-qt

Then reboot the machine and click the upper right hand corner of the screen at the user login and select “Plasma”.

[source: KDE - changing the way you use Qubes - #8 by Sven]

Enjoy!

3 Likes

Yeah! That worked! Thank you!

1 Like

Thanks @necker ! It worked for me as well but I ran into another bizzare issue. After shutting down my machine and booting it up again, when I try to launch any application, in plasma environment, after clicking on any application from the menu, nothing is happening, application window is not showing up as if I haven’t clicked on the application shortcut at all. But if log out and log into the XFCE, that application I tried to launch, is running fine and the application window is visible. Any ideas what could be causing such weird behaviour?

@chileab That’s interesting. Not sure what is causing the problem. Maybe create a new topic to attract more attention. Good luck!