Installed application on TemplateVM but not showing up on AppVM

I attempted to install the transmission bt client in the personal qube. I started the fedora-30 template qube as specified in this article and installed transmission.

I was not able to install any applications in the personal qube before which is why I had to refer to that article.

I was able to start transmission in the fedora-30 template qube and I also verified that it showing as installed in the fedora software center.

However whenever I try to launch transmission in the personal qube using the app shortcut or through the terminal, nothing happens. I have tried to search the personal file system with the find command for transmission but I could not find anything.

My goal is to get transmission to start in the personal qube. I am stuck at this point.

You’re probably only missing the last two steps:

  1. Shut down the TemplateVM.
  2. Restart all TemplateBasedVMs based on the TemplateVM.

To then see the “transmission” on you personal qube’s menu, follow the instructions in this page:

You’re not alone. This other user had the same problem. Currently Qubes does not hint users on how to install software. The only way to know is to see the documentation. Hopefully this is something that can be fixed in the future.

(Glad it’s solved @waterbottle! I’ve changed the title to make it more generic for the problem. This will make it easier for others to find)