App Icons not Showing Up


I’m a long-time Linux user (usually Debian), but I am brand-new to Qubes. I installed it earlier today and have been loving it so far, but I went to install some of my applications (Spotify, Element, Termius, etc.) and they aren’t showing up under the applications list.

Everything has been installed through the command line, and I am using the “personal” domain based off a Debian template (and yes, I am sure that I installed the apps using the personal AppVM).

The icons are not in the default list, or in the “Applications” tab of the Qube’s settings menu. I’ve tried refreshing (via the button the tab and via cli), but when I press the refresh button on the tab it seems to want to refresh for the Debian 10 template instead of for my personal AppVM. When I use the command line, I am able to specify “personal”, but it still doesn’t fix the issue.

I have verified that the programs create .desktop files, and have rebooted. I don’t know what is going on here, any help would be appreciated. Most of my work can be done from a web browser for the time being, and all the built-in apps are working fine, but I do need third-party app support to be working.

Here is the relevant documentation, I’ve referenced it for the CLI commands mentioned above for restarting/rescanning for new apps, but it doesn’t seem to work.


Hi @toxicwaste! Welcome to Qubes!

Since you’re new to it, there are a few key things that you have to learn since it works a bit differently from traditional linux distributions.

In short, software is installed on TemplateVMs on which your AppVM (“personal”, for example) are based. This is why when you hit “Refresh Applications” it booted the TemplateVM instead of "personal.

A bit of reading of the documentation will save you a fair bit of frustration. I remembering having a rough time in the beginning because I was avoiding reading the docs.

The documentation page you need for this particular issue is the following:

The App Icons will should show up if you install them like that. But just in case they don’t, only then should you take a loot at the documentation you were referring to.

I also suggest you take a look at the Getting Started page, if you haven’t already.

1 Like

Something you’ll also realize is that TemplateVMs are not directly connected on to the Internet (look for “updates proxy”).

By default only the package manager (“apt/dnf”) will reach the internet.

So in the case the software is not on your external software, if possible, the easiest way to install it is by adding a new source to your package manager ("/etc/apt/sources.list.d" or “/etc/yum.repos.d/”). But you should also take into consideration the security implications of adding an extra source.

There are other ways, but I won’t dig into them now.

Ok, so I need to install all my software on the TemplateVM instead of the AppVM, and the software will be installed on all AppVMs built with that template. That makes a lot of sence for why/how other things work. So I guess I can just install all my apps on the Debian template, then enable/disable them for my various VMs.

Thanks for the help!

1 Like

That’s pretty much it.

Then, once you start to get the hang of qubes you can do even more nice things. Take a peek at this thread, if you’re interested:

Best of luck on your QubesOS adventure! Any bump you come across that you can’t understand by reading the docs, just post here on the forum and we’ll try to help :slight_smile:

To be clear, you cant “enable/disable” them at all - at best you can
make them visible/invisible in the menu. All applications installed in
a Template are available in every qube that uses that template.

It’s for this reason that some users have many templates, with various
applications installed. This also helps to reduce the attack surface in
your qubes.

Makes sense. I already have a bunch of templates, i’m probably going to make more as time goes on.