Installation issue - Not asking for VNC because we don't have a network

“Not asking for VNC because we don’t have a network” / “X startup failed, aborting installation” / “Pane is dead”

getting the above error, bios only supports uefi not legacy. System meets all the hardware requirements, when installing through vmware everything works fine but no point as qubes is made to be installed bare metal.

Also tried the Qubes-20220820-kernel-latest-x86_64.iso, it installs but then screen tear on moving pane or windows like if you move a pane it breaks into many pixels and after sometime window appears.

Why is that when the hardware meets all the requirement why qubes does not install. There must be some fix for this. LEgacy boot is no longer supported on hardwares, why is there no support for uefi.

Nvidia gtx 1650 and intel uhd comes with the pc. What can be done to install help please.

Did you try

I tried the UEFI trouble shooting and mounted the anaconda partition from the usb installer. But in the EFI>BOOT folder there are two files. One is grub.cfg and BOOTX64.EFI not BOOTX64.CFG. so not sure whether the grub file need to be edited as BOOTX64 is in EFI format

i will try to add the kernel= edit from this page to grub.cfg

this kernel= line, add:

 nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off


nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off

noexitboot=1 modprobe.blacklist=nouveau rd.driver.blacklist=nouveau — intitrd.img

tried adding both the line to grub.cfg but does not work, getting the same error

Not asking for VNC because we don't have a network
X startup failed, aborting installation 
The installation cannot continue and the system will be rebooted
Press ENTER to continue

there was no kernel= line in the grub.cfg so added it along with the other lines

were these changes to be made to iso file?

in ISO file as well, in the EFI > BOOT folder there are two files BOOTX64.EFI and grud.cfg

@enmus how was this issue solved

@marmarek @Plexus @michael @adw @sven @deeplow If you guys can help

The EFI file is the GRUB binary, and it uses the grub.cfg file in the same folder. This is the grub.cfg that you need to edit.

So, you haven’t got a grubx64.efi file in that directory…?

So you have a line that looks like this:

module2   /vmlinuz-some-kernel-version kernel-parameters=true more-kernel-parameters=false nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off


Yes, if you couldn’t complete the installation, those parameters should at least get you to boot from the ISO successfully.

But you’ll also need to add them to /etc/default/grub after you’ve successfully installed, and then regenerate your grub config.

But at least it installs successfully, and then those things can be fixed via firmware or config tweaks.

So that’s at least one option if you can’t get this to work.

1 Like

Thanks that should help me solve this

1 Like

Please refrain from mass-tagging people like this, especially developers. If there is someone whom you know is interested in these kinds of issues, then that’s fine. But if it’s just to get attention, please abstain from doing it.


Can someone post their complete edited grub.cfg file please, just so I am clear?