Can't find the BOOTX64.cfg file

Hello there! I was out of the Qubes community for a while, but i finally got a computer that might suport Qubes again. I downloaded the 4.1 version (to be specific, the Qubes-R4.1.0-x86_64.iso file) and when I booted it up there was a problem: the installation freezes before displaying the installer

The last time it happened to me it was a UEFI problem that I solved by editing the BOOTX64.cfg file as indicated here, but on 4.1.0 iso the EFI/BOOT/BOOTX64.cfg path on the EFI partition doesn’t exist! Actually, the contents in the EFI/BOOT/ directory are:

ls EFI/BOOT/

BOOTX64.EFI  fonts  grub.cfg

Did something went wrong with my iso instalation or download? I triyed to find the BOOTX64.cfg file by typing

ls -R ANACONDA/ | grep BOOTX64.cfg

which gave me no resolts.

Any ideas? Hope you guys can help me.

-VeiodoCafé

computer specs?
have you try with legacy bios ?

1 Like

Memory: 16GB
CPU: Intel Xeon E5-2640 2.50GHz x86_64

Tks for the tip.
I have just tried to use legacy boot and it worked at first. But when the installer started to write the changes on disk the “unknown error” screen has pop up.

This documentation says to format the disk and try again, but since I did it the installer does not load when I enter the “Install Qubes R4.1.0” option nor the “Install Qubes R4.1.0 in basic graphics mode” option.

It just displays a black screen. Any idea? : )

try recreate installation medium, select disk and use automatic partition in storage configuration, tick encrypt, enter password and proceed installation. How you configure storage before ? you did a “manual” set or no ?

how long you wait when screen is black ?

Nope. I used automatic partition last time. I can’t proceed the installation because the initial screen (this one) is the only thing that is displayed. Any installation option I select is leading me to the black screen.

I also have format the installation media, but nothing changed.

Over 20 minutes

The documentation says to wipe all or delete all partitions, which is not the same as to format the drive, but i guess you meant on wiping.

I head a similar case while experimenting, and I had to clean the disk with Windows’ diskpart. I pulled it out from the laptop and attached it to the other via caddy, only then to be allowed to continue installation. I guess it would help to use any live distro on a usb stick, I just didn’t want to use yet another usb stick sticked to my Qubes laptop before I install it.

Try use discrete gpu, if you have. nv 295 would do.
and btw there’s a grub.cfg, it’s equivalent to bootx64.cfg.

Ok guys, good news! By booting through legacy bios and entering “Install Qubes R4.1.0 in basic graphics mode” option while holding ENTER, I was able to almost start the installer. Well, at least it’s not giving me a black screen again, but an error message:

12:53:58 Not asking for VNC because we don’t have a network
12:53:58 X startup failed, aborting installation
The installation cannot continue and the system will be rebooted
Press ENTER to continue





Pane is dead (status 1, Wed Feb 16 12:53:58 2022)

Now I have a kind of stupid problem… The documentation to this error says to

  1. Disable secure/fast boot and use legacy mode :heavy_check_mark:

  2. Enter GRUB, move the selection to the first choice, and then press the Tab key.

  3. Add some instructions to the kernel line

But I don’t know how to enter grub from the installer. Was the grub supposed to be displayed before this screen?

what’s your gpu ? probably there’s a problem with your gpu.
you could try to find workround, and for editing kernel parameter (grub config file) just press ‘e’ when in grub menu, it would give you an text editor, and you may add / change kernel parameters.

Gpu: Nvidia GeForce 8400 GS

For some reason the grub menu doesn’t show up for me.

Maybe there is some boot parameter I can write on the initial screen (by pressing tab) that will load the grub menu.

Isn’t that screen grub menu?

1 Like

Hey, tks! I have typed the

nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off

directly there by pressing TAB and it worked. Tks enmus

1 Like