Install software in templates

Installing apps that stay persistent would be nice. Adding the “software” choice from a repo list apparently does nothing to cement software to this OS’s appVM based on a template. Two things are annoyingly persistent: “Could not display cancel Search in Software” and, Unable to install “(null)” as not supported.

[quoting another newbie’s experience] “All I want to do is install some software and make it easy to run when I open the qube. This should be super easy but it isn’t. It’s issues like these that make it very hard to make the switch”.

Yes, I too have spent days into the wee hours trying to bind/make persistent/etc. downloaded apps to keep from simply vanishing FROM ANY AND ALL TEMPLATES. Pick a card. Any card. It doesn’t stick. It is Qubes biggest hole when a new user dedicates the time it takes to find this answer that should be up front in the doc that sends you to the doc “See How To Install Software” that eventually sends you to a mind numbing few 'net pages of…more hair pulling. I built my first PC, an XT, in 1987. I have not entered so many commands in terminals since DOS 3.0. Persistence still doesn’t work on my partitioned NVME, an NVME in a portable USB, nor two sanitized SSD’s.

LibreOffice suite is not in any of the repos I see in 4.1.2. though Micah’s repo shows it in a repos list on one of his pages.

I have yet to find the source of the packages. Entering the four lines regarding free and non-free apps vanishes across the horizon.

The first thing I see upon booting from a USB drive is: USB is not restricted consider rd.qubes.hide_all_usb or usbcore.authorized_default=0 I did consider that at a terminal. I have no idea what it improved, prevented, or activated.

The LibremPC or Nitro I drool over seems to be an almost thousand dollar non-solution in the search of an easy-to-live-with and secure OS.

Could you describe how you are installing software?

I choose a template that seems appropriate. I thought and used fedora 37 for too many attempts. After that I tried every single template on each of my four installs on 500GB internal NVME, 120GB SSD, partitioned 500GB NVME (Windows in one partition; Qubes in the other), 500GB NVME in a portable USB. I install an app, something from LibreOffice, and ignore the Launch pop-up at the end of the install and shutdown the qube. I restart the qube. Go to Files. Double-click on a file and the dreaded Could not display Cancel Search in Software pop-up greets me. I cry.

I have an AMD 64 bit Ryzen 3 with 32GB DDR4. I know this box. I built it myself. The problem may be my hardware, or a setting I cannot find. I’ve read all the docs and many 'net pages. This is the first time in my entire computers and software life I am stumped.

The apps I attempt to install come from the Catalog that loads when I click on software in the template.

TLDR; if you install software using the program “Software”, you must run it from the template and choose the source of package “Fedora Linux (RPM)”

If I’m not mistaken, the “Software” app in Fedora is using Flatpak for most programs nowadays. By default, they are installed system-wide in /var/lib/flatpak/ which is outside the persistent area of an AppVM, so either:

  • you install programs this way from the template: depending on what text you have under the blue button “Install”, you have to choose between “Fedora Linux (RPM)” or “Fedora Flatpak”, choose the RPM method because it will integrates well into the menus. See Finding and installing Linux applications :: Fedora Docs
  • you install the programs using flatpak in the user directory (flag --user for flatpak commands in command line), but I don’t know if this is possible from the GNOME “Software” program. I tested this one and it’s working fine

In any case, when using flatpak, you won’t have a menu entry :frowning: I guess it’s something that should be fixable quite easily in Qubes OS but someone would have to do the job.

Thanks for these suggestions!

Actually, using Software won’t work out the box, you would need to enable network to the template, which isn’t best practices.

See this documentation page explaining how to install software in a template: How to install software | Qubes OS

and the subsection explaining why templates are offlines: How to install software | Qubes OS (they use a proxy qube that download packages for them, but it seems it’s not fired up by Software)

There is an issue opened:

(which superseeded Software update with gnome-software in TemplateVM not working · Issue #3815 · QubesOS/qubes-issues · GitHub )

1 Like

Solene, Thank you so much for putting this together for me. I have read some of it many times in the 3-ring binder I made but to have all that you sent is a fountain of information I was desperately needing.

My goal is to make a successful system so I will have an excuse to have a Librium Mini soon, but I needed to see exactly what I would be getting into.


The Gnome Software tool is simply broken - it does not recognise when the dnf
system is configured to use a Proxy. This is not a Qubes issue, but you
feel the pain in Qubes because the templates are offline and use a proxy
by default.( As explained in the docs you have been pointed at.)

One way around this is to run the Software tool in a qube to identify
the packages you want, and then install those packages in the template
using sudo dnf install ...

Debian templates do not have this problem.
If you use a front end like aptitude it will honour the proxy setting
and just work ™.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.

I opened an issue to ask for the removal of the “Software” menu entry until it works. Because it’s confusing to see it deployed and realize it’s not working.

1 Like

I saw that - there are already issues relating to this.

Thanks so much for your attention and the creation of a ticket. The Qubes group are really helpful. I really love this, already.

Yes, after many attempts I thought adding Software to the repos was something I simply did not know how to use properly or it was not to be used for app installs. This morning I will more properly add to the repos lists in the Fedora-37 template and learn more from there.

I expected to learn a lot in the first few weeks, so I am not totally frustrated. I am only several days into this project and my ultimate goal is to know quite enough to know how to use Qubes OS so I can reward myself with a Librem or Nitro. Needless to say, I am motivated!

1 Like

2 posts were split to a new topic: Qubes OS doesn’t detect my printer or scanner