Qubes OS doesn't detect my printer or scanner

Qubes can’t see either of my two printers nor either scanner.
The hunt for approved, safe source for downloadable software is a like herding cats.
The forum is so full of Qubes problems discussion it begs the question, “Is it ready for every day use or just a hobby to see if it can be kept flying?”

I appreciate the helpful replies but after an eight day all day every day evaluation of Qubes OS I’m outta here. It needs a lot of work.

Could you create a new topic if you want help for this issue?

You would need to tell if they are USB or networked.

Qubes OS is a nice security specialised OS. As with security, it’s always a trade-off with usability/user experience. For your device issue my guess is:

  • network devices: they use the protocol zeroconf (port udp 5353) to work, which is only available in the sys-net qube for security reasons
  • USB devices: you need to assign them to the qube where you want to install the device

I wrote a quick quide to install a remote scanner in sys-usb Solene'% : Easily use your remote scanner on Linux (Qubes OS guide) but the changes aren’t persistent, fortunately enough for me, I use it once in a while. Almost the same guide would work for a remote printer, but one would have to install and run cups service, and use a web browser on http://localhost:631 (in sys-usb) to configure the printer. This could be made persistent by creating a dedicated qube and routing port 5353 to it though.

1 Like

@Robd1 I moved these two posts to a new topic, please feel free to edit the title if it doesn’t represent your intention acurately! :slightly_smiling_face:

Using Qubes 4.1 or 4.2RC?

I’ve had surprising problems with 4.2RC and have not been able to connect my USB HP printer in either Fedora or Debian, and despite having all the required software installed and even having HP printer Device Manager detect my printer in Debian.

The printer worked smoothly in Debian 11 in Qubes 4.1.

My printers and scanners were Bluetooth on Windows10. Never network. For Qubes I tried straight ahead USB but no luck.

Unix, DOS, OS/2 (my personal favorite), Red Hat, Windows (all flavors), and now Qubes. I feel like I’m back where I started.

The obvious OS security compromise is Tails.

Could you explain the steps you made to install your printer? We can’t provide much support without information :slight_smile:

1 Like

Thank you for your continued patience but I’m having the same problems I had a few years ago when Qubes OS was new. I do applaud the effort made since it’s inception. I am sadly ending my effort and interest. The team should really concentrate on making Qubes OS user friendly…and stable.

I wish you a successful continuation :wave:

Indeed, Qubes OS lacks contributors to polish it even further, and it’s still far from being accessible to everyone.